murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

Client disconnected from server

Fri Nov 20, 2015 6:37 pm

Hi,

We are receiving an error when trying to add a new device and when we go to save the settings, it says "Client was disconnected from the server".
Are we doing something wrong to be receiving this error?

Thanks in advance for guidance,
Bill

User avatar
johan
GpsGate
Posts: 14958
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Client disconnected from server

Fri Nov 20, 2015 6:44 pm

1. Make sure your server is up to date. All "green" under SiteAdmin -> Plugins.

Ir if still does not work after update:

2. Check if any errors are generated in the ErrorLog when you try to save the Device. You find the ErrorLog under C:\GpsGateServer\ErrorLog on the Windows server where GpsGate is installed.

Regards,
Johan

GpsGate Support

murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

RE: Client disconnected from server

Fri Nov 20, 2015 6:49 pm

Thanks Johan. We are going to check now.

murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

RE: Client disconnected from server

Fri Nov 20, 2015 8:39 pm

Johan - It is showing the following information after trying to add adevice:

2015-11-20 12:53:55.8508 | Error | 7 | ExtendedRpcDispatcher.OnError | Error executing JSON method | GpsGate.Client.GateDisconnectedException: Client was disconnected from server
at GpsGate.Client.GpsGateClientCmd.CmdToServer(FRCMD cmdToServer)
at GpsGate.Admin.Service.AdministrationFacade.CmdToServer(FRCMD cmd)
at GpsGate.Admin.Service.UserFacade.m_SetDevice(UserBag user, UserDeviceBag device, Int32 iIdx, GateUser writer, Session session)
at GpsGate.Admin.Service.UserFacade.m_SaveUser(Int32 iApplicationID, UserBag user, Session session, UserTemplateBag accessMask)
at GpsGate.Admin.Service.UserFacade.SaveUser(Int32 iApplicationID, UserBag user)
at GpsGate.Admin.Service.json.User.SaveUser(Int32 appId, UserBag user)

User avatar
johan
GpsGate
Posts: 14958
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Client disconnected from server

Fri Nov 20, 2015 9:39 pm

I assume that was the log file named "IIS 2015-11-20.log", and what about the log file named "NMEA 2015-11-20.log" ?

Regards,
Johan

GpsGate Support

murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

RE: Client disconnected from server

Fri Nov 20, 2015 9:48 pm

Here is the NMEA 2015-11-20 Last log entry:

2015-11-20 12:53:55.7416 | Error | 5 | NmeaConnection._LogBinary | Binary: 0x24,0x46,0x52,0x43,0x4D,0x44,0x2C,0x2C,0x5F,0x41,0x64,0x64,0x4F,0x72,0x55,0x70,0x64,0x61,0x74,0x65,0x44,0x65,0x76,0x69,0x63,0x65,0x2C,0x4E,0x6D,0x65,0x61,0x2C,0x31,0x31,0x2A,0x35,0x33,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x4F,0x77,0x6E,0x65,0x72,0x49,0x44,0x2C,0x31,0x37,0x37,0x2A,0x33,0x32,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x44,0x65,0x76,0x69,0x63,0x65,0x4E,0x61,0x6D,0x65,0x2C,0x43,0x61,0x6C,0x41,0x6D,0x70,0x20,0x41,0x70,0x70,0x4D,0x73,0x67,0x2A,0x37,0x41,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x49,0x4D,0x45,0x49,0x2C,0x34,0x35,0x34,0x32,0x31,0x32,0x35,0x30,0x38,0x39,0x2A,0x34,0x37,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x45,0x6D,0x61,0x69,0x6C,0x2C,0x2A,0x30,0x33,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x50,0x72,0x6F,0x74,0x6F,0x63,0x6F,0x6C,0x49,0x44,0x2C,0x2A,0x37,0x34,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x4D,0x53,0x49,0x53,0x44,0x4E,0x2C,0x2B,0x31,0x36,0x35,0x30,0x33,0x39,0x30,0x34,0x37,0x37,0x38,0x2A,0x35,0x45,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x53,0x74,0x61,0x74,0x69,0x63,0x49,0x50,0x2C,0x35,0x34,0x2E,0x32,0x30,0x31,0x2E,0x31,0x38,0x34,0x2E,0x31,0x33,0x35,0x2A,0x37,0x38,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x53,0x74,0x61,0x74,0x69,0x63,0x50,0x6F,0x72,0x74,0x2C,0x32,0x30,0x35,0x30,0x30,0x2A,0x37,0x39,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x44,0x65,0x76,0x69,0x63,0x65,0x4D,0x61,0x70,0x49,0x44,0x2C,0x33,0x33,0x37,0x2A,0x31,0x31,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x44,0x65,0x76,0x69,0x63,0x65,0x44,0x65,0x66,0x69,0x6E,0x69,0x74,0x69,0x6F,0x6E,0x49,0x44,0x2C,0x31,0x39,0x2A,0x34,0x37,0x0D,0x0A,0x24,0x46,0x52,0x56,0x41,0x4C,0x2C,0x48,0x69,0x64,0x65,0x50,0x6F,0x73,0x69,0x74,0x69,0x6F,0x6E,0x2C,0x30,0x2A,0x36,0x36,0x0D,0x0A, |
2015-11-20 12:53:55.7416 | Error | 5 | TcpConnection.m_ToProtocol | williamsonjhn@TcpConnection, 127.0.0.1:49411 | System.InvalidOperationException: Multiple devices found for Static IP = 54.201.184.135 Protocol ID = CalAmp
at GpsGate.Online.Directory.DAO.DeviceDAOSQL.LoadByIPAndProtocol(String strIP, String strProtocolID)
at GpsGate.Online.Directory.DAO.DeviceDAOSQL.Update()
at Franson.DAO.BOItem.Update()
at GpsGate.Online.Directory.Device.Update()
at GpsGate.Online.Directory.Command.AddOrUpdateDeviceCmdExe.Commit()
at GpsGate.Online.Net.GpsGateProtocol.m_ExecuteCmd(Sentence nmeaSentence)
at GpsGate.Online.Net.GpsGateProtocol.ToGpsGate(Sentence nmeaSentence)
at GpsGate.Online.Net.GpsGateProtocol.TranslateFromDevice(Byte[] arrData, Int32 iStart, Int32 iLength)
at GpsGate.Online.Net.NmeaConnection.DeviceToProtocol(Byte[] arrData)
at GpsGate.Online.Net.Tcp.TcpConnection.m_ToProtocol(IAsyncResult asyncResult, Byte[] arrPooledData)

User avatar
johan
GpsGate
Posts: 14958
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Client disconnected from server

Fri Nov 20, 2015 9:50 pm

This is the error:

Multiple devices found for Static IP = 54.201.184.135 Protocol ID = CalAmp

Please leave the Static IP field blank.

Regards,
Johan

GpsGate Support

murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

RE: Client disconnected from server

Fri Nov 20, 2015 10:00 pm

Where is the static ip field located at?

Cheers
Bill

User avatar
johan
GpsGate
Posts: 14958
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Client disconnected from server

Fri Nov 20, 2015 11:13 pm

It is the "IP/Port" test field under "Device 1"

Regards,
Johan

GpsGate Support

murph5011
Posts: 22
Joined: Thu Aug 13, 2015 9:35 pm
Location: USA

RE: Client disconnected from server

Sat Nov 21, 2015 12:03 am

Thanks Johan. Everything is working flawlessly!!

Return to “GpsGate Server - How to setup and use”