User avatar
johan
GpsGate
Posts: 14663
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

FIX: Google provider failed.

Wed Oct 28, 2015 2:10 pm

Note: for an updated version of this and other articles, we recommend you to check our knowledge base here

ISSUE

Your GpsGate Server sends you this automated email:

Hi, this is an automated email from your GpsGate Server. Google provider failed. 10 Google geocoding errors in sequence. Google geocoder is disabled.

Or you get blank addresses in your reports when using Google Maps as geocoder.

CAUSE

You most likely use a "free" Google Maps key which limits you to a daily quota of geocoding requests. (Typically 2500 per day). After this quota is used, all addresses will be blank.

SOLUTION

If you have a Pay-as-you-go server, please contact support to activate Google Maps.

For legacy license servers you can purchase a Google Maps license here:
http://gpsgate.com/purchase/google_maps

Or you can use any of the other available map / geocoding options:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=10087

GpsGate Native Map Based on OpenStreetMap data. (included for servers with active support).
http://gpsgate.com/blogComment/gpsgate_geocoder

Use POIs for geocoding
http://gpsgate.com/blogComment/pois_for_reverse_geocoding

Create new geocoder "stack". You may for example want to create a new geocoder which first checks geofences, then POIs and as a final resort CloudMade and/or Google.
http://forum.gpsgate.com/topic.asp?TOPIC_ID=12855

If you want to apply a new geocoder on a historical report, the report data needs to be reprocessed.
http://forum.gpsgate.com/topic.asp?TOPIC_ID=13659

DISABLE EMAIL NOTIFICATION

If you just want to disable the notification you can do this under SiteAdmin -> Maps -> Geocoder Errors

Regards,
Johan

GpsGate Support

thijs
Posts: 5
Joined: Mon Jan 20, 2014 1:45 pm

RE: FIX: Google provider failed.

Thu Jun 16, 2016 7:03 pm

I enabled the geocoder error emails, and I see these errors in the mail nightly now. Not a real problem, but even when I disable the email notification the emails keep coming every night. It seems to me that disabling the notifications doesn't work.

Return to “GpsGate Server - How to setup and use”