gpsgate.user
Posts: 68
Joined: Mon Sep 17, 2012 6:49 am

No data in sending email report manually

Fri Nov 30, 2012 4:48 am

Hi Support,

When sending email report manually, I noticed that only registered email on the server is working but emails not registered it will send but it show only the header of the template and no data. Please check.

Thanks

Regards,
gpsgate.user

User avatar
johan
GpsGate
Posts: 14887
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: No data in sending email report manually

Fri Nov 30, 2012 4:10 pm

Note: for an updated version of this and other articles, we recommend you to check our knowledge base here

Check this

* Make sure all your plugins are up to date, all "green" under SiteAdmin -> Plugins.

* Please take a look at the _ReadData privilege, it will determine which data is included in a report. A user must have _ReadData access to the Tags included in the report.

* If you use an Event Rule report, please make sure the recipient has _ReadEventRule access to the Event Rules included in the report.

How it works

When emailing a report to a registered user. That users _ReadData privilege will be considered.
When emailing a report to an unregistered email address, the sending users _ReadData privilege will be considered.

* The _ReadData privilege and _Me tag introduces a whole new concept on how to setup your customer applications. Reports, Views and Event Rules can be made much more generic and you control who can see what using _ReadData and _Me. This will save you a lot of work.

Using _ReadData to determine who can see which vehicle data http://forum.gpsgate.com/topic.asp?TOPIC_ID=15060

Using the _Me tag to only see your own data http://forum.gpsgate.com/topic.asp?TOPIC_ID=15061

Useful tools

You can also check under SiteAdmin -> System Info -> Queue Viewer in which user context a report was generated and emailed. Check the "Session User" column.

If you right click on a user/vehicle and select Overview you can see which reports, and which data in the reports a user has access to see. In the latest Reporting update you can also see when reports has been emailed to the user.

Regards,
Johan

GpsGate Support

gpsgate.user
Posts: 68
Joined: Mon Sep 17, 2012 6:49 am

RE: No data in sending email report manually

Mon Dec 03, 2012 10:25 am

Hi Johan,

All the plugins are updated.

All user under _ReadData are selected (Administrator role).

I'm using Administrator account to login and tried again the unregistered email address but still blank. Please check.

Thanks

Regards,
gpsgate.user

User avatar
johan
GpsGate
Posts: 14887
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: No data in sending email report manually

Mon Dec 03, 2012 3:45 pm

We cannot repeat this problem.

As a work around, please create a user for this email address. Note that a user that will just receive reports over emails will not consume a license.

Regards,
Johan

GpsGate Support

User avatar
johan
GpsGate
Posts: 14887
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: No data in sending email report manually

Mon Dec 03, 2012 3:51 pm

One possible thing you can check is that if you send the report to an email address that belongs to a user of another application. This user has no _ReadData access to the current application and as a consequence the report is blank.

If that is not the case, see my previous answer for a work around.

Regards,
Johan

GpsGate Support

gpsgate.user
Posts: 68
Joined: Mon Sep 17, 2012 6:49 am

RE: No data in sending email report manually

Tue Dec 04, 2012 10:54 am

Ok Johan, got it. Thanks.

Regards,
gpsgate.user

Return to “GpsGate Server - How to setup and use”