vasja
Posts: 92
Joined: Wed Mar 26, 2008 2:25 pm

IMEI not recognized

Fri Jun 22, 2012 2:57 am

Hi,
I have a device which sends data to server and I can see it on Terminal as this

[2012-06-21 23:52:52] (192.168.5.34:1027/SmartPipe/tcp) Disconnect

[2012-06-21 23:52:52] (192.168.5.34:1027/SmartPipe/tcp) Client: IMEI=000000668615568 $GPRMC,204914,A,4438.8995,N,02015.9243,E,0,254,210612,,*1E

[2012-06-21 23:52:52] (192.168.5.34:1027/SmartPipe/tcp) Connect

I have user created and user has a device which is of type smartpipe NMEA and it has IMEI=000000668615568 just like in Terminal, and yet Terminal show this message as uhnknown and it does not assign it to this user. What is wrong with this? GpsGateServer latest version.

Best regards,


Vasja

User avatar
johan
GpsGate
Posts: 14862
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: IMEI not recognized

Fri Jun 22, 2012 2:09 pm

The problem is that IMEI 000000668615568, is no IMEI number, or at least it does not follow standards.

The solution is to enable "Unsafe" authentication for SmartPipe. You do that with this SQL query:

UPDATE settings SET value_data = '1' WHERE namespace = 'SmartPipe' AND value_name = 'Unsafe';

Restart NMEA Service under SiteAdmin -> Service for the change to take effect.


Regards,
Johan

GpsGate Support

vasja
Posts: 92
Joined: Wed Mar 26, 2008 2:25 pm

RE: IMEI not recognized

Fri Jun 22, 2012 2:39 pm

Thanks - two times!

Vasja

Return to “GpsGate Server - How to setup and use”