User avatar
johan
GpsGate
Posts: 15220
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

Plugin: Enable SMS over HTTP

Mon Mar 01, 2010 1:33 am

Enable SMS over HTTP

This provider is an alternative to "GpsGate SMS Proxy". It will accept incoming SMS over HTTP, and send outgoing SMS using a HTTP GET request. In this way you can easily make an integration to existing web services that provide SMS.

How to install
1. Login to SiteAdmin
2. Go to Plugins
3. Download and install the latest Patch.v4 plugin.

Configure
1. Login to SiteAdmin
2. Go to "Settings -> SMS"
3. Select "HttpMessageProvider" in drop down.
4. "Name", can be anything.
5. "Url" should be the full HTTP URL to a GpsGate ready SMS web service. (Or to your integration code, see below).
6. "Username" and "Password" for authetication.
7. Click Save.
8. Configure web service to send SMS to your GpsGate Server.

Now SMS is enabled on your server.

Troubleshooting
You can use the "Send Test SMS" feature under "Settings" in SiteAdmin.

All sent and received SMS can be monitored in the Terminal. You can also send SMS directly from the Terminal. More info:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=10740

FOR DEVELOPERS ONLY

Outgoing SMS from GpsGate Server
GpsGate Server sends an SMS using the following HTTP GET request
URL?username=user&pw=xyz&clientaddress=+4671823737&message=Hello&transport=sms&id=12

Where "URL" is the url you specified when adding the "Message Provider" in step 7. above.

If the request to send an SMS fails the HTTP error code should be set. GpsGate will in that case try again every 15 minutes, and give up after 8 hours.

GpsGate Server -> HTTP -> (Your integration) -> SMS web service

Incoming SMS to GpsGate Server

After saving the HttpMessageProvider, please click Edit again to see the URL you should send incoming SMS to.

SMS web service -> (Your integration) -> HTTP -> GpsGate Server

NOTE! Make sure port 8008 is opened in your firewall!

The URL explained

username, pw - This is the username and password specified when configuring the "Message Provider". For incoming SMS the username and password must match, or the response will be HTTP Forbidden.

clientaddress - This is the phone number in MSISDN format. That is a "+" + country code + aread code + number. E.g. +1783016454

message - The SMS message itself.

transport - Type of message. This should be set to "sms" for SMS, but can also be set to "orb" for ORBCOMM. If left out "sms" is assumed. This integration method can be used for any kind of message based communication, including satellite based messages.

clientdate - UTC date when message was sent from device/phone. Format "DDMMYY".

clienttime - UTC time when message was sent from device/phone. Format "HHMMSS.ss"

id - ID for message.

Related topics

Enable SMS for GpsGate Server http://forum.gpsgate.com/topic.asp?TOPIC_ID=7829

Regards,
Johan

GpsGate Support

miro1
Posts: 45
Joined: Tue Sep 07, 2010 6:15 pm
Location: Slovenia
Contact: Website

RE: Plugin: Enable SMS over HTTP

Sat Oct 16, 2010 3:14 am


ricksikh
Posts: 8
Joined: Wed Jan 04, 2012 1:34 pm

RE: Plugin: Enable SMS over HTTP

Wed Jan 04, 2012 1:54 pm

Hi,

Im trying to integrate a Web SMS Service into our gpsgate application.

The URL provided by them is like this :

http://xyz.com:8080/WebSMS/SMSAPI.jsp?username=xxxxxx&password=xxxxxx&sendername=xx&mobileno=919999999999&message=Hello

Now,
GpsGate Server sends an SMS using the following HTTP GET request:
URL?username=user&pw=xyz&clientaddress=+4671823737&message=Hello&transport=sms&id=12&routelabel=x

Where URL should be the url that I mentioned above for the SMS Service I want to use.

Now when we SEND A TEST SMS through Gpsgate siteadmin , It asks us to enter a mobile number to deliver the msg to. And a predefined text is bieng sent to that number.
I have tested this thing by installing Clickatell Plugin, and its working all good.
The Clickatell Gateway URL is like this:

http://api.clickatell.com/http/sendmsg?api_id=1234&user=foo&password=xyz&from=4412345676

This Clicktell Url is neither asking for a destination mobile number nor a message text to send.

But the URL provided by the SMS Service i want to use has parameters asking to enter mobileno and message.
Here is where im getting stuck.

What URL should I specify, when adding a HTTP Message Provider for this service ?

Thanks.

User avatar
johan
GpsGate
Posts: 15220
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Plugin: Enable SMS over HTTP

Wed Jan 04, 2012 2:09 pm

You need to write some kind of "proxy" between the SMS service and GpsGate.

SMS Service <-> Your proxy <-> GpsGate

Regards,
Johan

GpsGate Support

ricksikh
Posts: 8
Joined: Wed Jan 04, 2012 1:34 pm

RE: Plugin: Enable SMS over HTTP

Wed Jan 04, 2012 3:47 pm

Referring to the Url I mentioned , Can you please give an idea about how that proxy should look like , that need to written between SMS service and gpsgate ?

User avatar
johan
GpsGate
Posts: 15220
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Plugin: Enable SMS over HTTP

Wed Jan 04, 2012 4:28 pm

For incoming SMS from the SMS service to GpsGate, your proxy needs to receive the HTTP request from the SMS service, decode the parameters in the URL, then build a new URL using the GpsGate HTTP SMS format and make a HTTP GET to GpsGate using that new URL.

For outgoing SMS from GpsGate to the SMS service, your proxy needs to receive the HTTP request from GpsGate, decode the parameters in the URL, then build a new URL using the SMS service format, and make a HTTP GET using the new URL to the SMS service.

If this is part of a customer case with some substance we can also consider helping you with this integration, in that case, please contact support@gpsgate.com

Regards,
Johan

GpsGate Support

ricksikh
Posts: 8
Joined: Wed Jan 04, 2012 1:34 pm

RE: Plugin: Enable SMS over HTTP

Thu Jan 05, 2012 11:32 am

While specifying the url in the HTTP message provider i created , I have entered the following SMS Gateway URL for the SMS service i want to use.

http://api.xyz.com?User=xxxxx&passwd=xxxxxx&mobilenumber=xxxxxxxxx&sid=xxxxxxxx

Now when im sending a Test SMS , it is getting delivered on the number specified in above url.

Its not getting delivered on the number which im entering while sending test sms.

How can i get it delivered to the number that im specifying for Test Sms ?

rajiv
Posts: 120
Joined: Thu Nov 27, 2014 2:27 pm

RE: Plugin: Enable SMS over HTTP

Tue Feb 23, 2016 11:18 am

Can someone pl share a sample proxy for outgoing sms ?

Originally posted by johan

For incoming SMS from the SMS service to GpsGate, your proxy needs to receive the HTTP request from the SMS service, decode the parameters in the URL, then build a new URL using the GpsGate HTTP SMS format and make a HTTP GET to GpsGate using that new URL.

For outgoing SMS from GpsGate to the SMS service, your proxy needs to receive the HTTP request from GpsGate, decode the parameters in the URL, then build a new URL using the SMS service format, and make a HTTP GET using the new URL to the SMS service.

If this is part of a customer case with some substance we can also consider helping you with this integration, in that case, please contact support@gpsgate.com

Regards,
Johan

GpsGate Support

Return to “GpsGate for Developers”