Page 1 of 1

Creating maplib files

Posted: Sat May 29, 2010 2:28 am
by geolog
I have approx. 420 bmp air photos that have been reduced to 1030*1030 sized images.
I have built a simple program that reads an access database table containing file names and the three points for scaling.

I open a blank.maplib file, i create in GPSTools Studio and then go to create newmapData as follows

airmaplib.open(dataloc & "blank.MapLib)
Airmapdata=airmaplib.NewMap Data(fname,mname)

fname=A10_low.bmp
mname=A10

when I run this airmapdata command I get an Exception
Matching image decoder not found

I have no problem creating the lib by hand in GPSTools Studio and tying each co-ordiante in.

using ver 2.31 gps tools. So why the differnce between the SDK and the studio? AM I missing a declaration?
Any help greatly appreciated.

RE: Creating maplib files

Posted: Sat May 29, 2010 3:21 am
by geolog
Solved the problem. It had nothing to do with the image.
There was a typo in the directory location.


So the error should be 'FILE NOT FOUND'

Instead of Matching image decoder not found.

thanks

shaun dykes