daveW
Posts: 34
Joined: Sat Aug 27, 2011 1:14 am

Queclink GL300: invalid GTFRI message data

Sat Aug 04, 2018 3:10 pm

I've recently purchased a GL300 (reported protocol 301001 = GL300 New Version v 16.01, software version A10V04) and am trying to integrate it with my GpsGateServer. I've used the GL300 Manage Tool to configure the unit: in particular, I'm using "TCP short connection forced mode" to communicate with the server and "close GPS chip after retrieving GPS data". In GpsGateServer, I've connected to the specific GL300 using the standard GL300 device type (with a few variables successfully added to the Device Mapper template)

The GL300 is located out in the open & every 5 minutes indicates that GPS lock is being achieved (ie fast flashing of GPS LED followed by steady on for about 60 secs, since I've set GPS Fix Delay to 60secs). The regular GTFRI messages from the GL300 arrive at my GpsGateServer (as indicated by System Tools: Terminal) but all are classified as having invalid data (in Terminal & in Application Track Point list). Why?
Curiously any GTNMR messages (indicating motion started/stopped, but with similar content to GTFRI messages) are treated as valid.
Any ideas gratefully received.

daveW
Posts: 34
Joined: Sat Aug 27, 2011 1:14 am

Re: Queclink GL300: invalid GTFRI message data

Sat Aug 04, 2018 6:33 pm

The answer was already in the post describing how to setup GL300 here https://forum.gpsgate.com/viewtopic.php?t=10248
Just need to increase Invalid Timeout duration (from 60secs) in GL300 device type.

Return to “GPS trackers, AVL hardware, SIM subscriptions etc.”