Brian
Posts: 7
Joined: Wed Mar 05, 2008 8:26 pm

Problem installing 1.3.2.483

Wed Mar 05, 2008 9:55 pm

Hi

I start the install wizard, it confirms that all the prerequisites are present, suggest GPSgateServer as the DSN, but when I then click Next I get the errors below.

I've rebooted, closed the other app that uses MySQL, checked that the ODBC driver is installed, still no joy. Servr 2000+latest SPs, MySQL 5.0.

Any ideas?

Brian

---------------------------

---------------------------
Test: CREATE Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: INSERT Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: LOCK Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: ALTER Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: UPDATE Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: SELECT Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: DELETE Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)Test: DROP Failed with message: ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)ERROR [HY000] [MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC'@'localhost' (using password: NO)
---------------------------
OK
---------------------------

User avatar
Fredrik
Posts: 1155
Joined: Fri Mar 02, 2007 1:04 pm
Location: Sweden
Contact: Website

RE: Problem installing 1.3.2.483

Wed Mar 05, 2008 11:40 pm

Hi,
This is a really odd error that shows up in rare occasions, though mostly on win2000 it seems. We haven't been able to track it down fully yet since it hasn't been completely reproducible.

Google for "Access denied for user 'ODBC'@'localhost'" and you'll find maany people having this problem on
all sorts of MySql installations. Some users seems to have successfully bypassed it by granting full db-privileges to the ODBC-"user" (this is unverified!).
http://www.onlamp.com/pub/a/onlamp/2006/12/14/revisiting-ruby-on-rails-revisited.html?page=2
http://forums.mysql.com/read.php?52,157896,165867#msg-165867
http://forums.mysql.com/read.php?37,166033,169496#msg-169496
Personally, I seriously doubt this is The solution, but I guess you could try it if all else fails.
Do have the possibility to switch to win XP Pro or 2003 perhaps?

We'd really like to solve this problem once and for all. We'll try to reproduce it during the week. Keep us informed if you make progress.

Regards,
Fredrik

Franson Support

altf4
Posts: 1035
Joined: Mon Feb 04, 2008 8:05 pm
Location: Thailand
Contact: Website

RE: Problem installing 1.3.2.483

Thu Mar 06, 2008 6:50 am

ODBC@localhost mean simply the ODBC Client does not submit a password.

look very much like a not working DSN ... (or a User dsn instead of a system DSN)

if you connect with Linux (using mysql client the error message states mysql@localhost ...
if you not authenticate yourself .. the username is set of the client used.


Brian: you need to check the configuration of the DSN first ...

make sure: its a System DSN (on Windows 2000 you can select a storage of DSN .. it MUST BE System)
username and password for mysql correct. (you will get a error message right away if there is somethings not correct)
and on windows2000 ODBC you will have the option trough a pulldown box to select the database/tables
if this boxes are empty .. you do not have a coinnection to the database with the DSN.




--
Backups are for WIMPS!

Brian
Posts: 7
Joined: Wed Mar 05, 2008 8:26 pm

RE: Problem installing 1.3.2.483

Thu Mar 06, 2008 2:38 pm

Originally posted by altf4
Brian: you need to check the configuration of the DSN first ...

make sure: its a System DSN (on Windows 2000 you can select a storage of DSN .. it MUST BE System)


Altf4: thanks. AIUI the GPSgate setup wiz should set up a DSN for you - but this was failing, as was setting one up manually.

Brian
Posts: 7
Joined: Wed Mar 05, 2008 8:26 pm

RE: Problem installing 1.3.2.483

Thu Mar 06, 2008 2:44 pm

Originally posted by Fredrik

Hi,
This is a really odd error that shows up in rare occasions, though mostly on win2000 it seems. We haven't been able to track it down fully yet since it hasn't been completely reproducible.


Hi Fredrik

After much messing around and uninstalling/reinstalling MySQL and the ODBC driver, I eventually got it working by going into the MySQL instance configuration wiz and setting it to create an anonymous account. Not ideal I know, but it'll do for testing.

BTW: just some feedback, I found the ODBC connection setup tab in the setup wiz confusing - I assumed it'd create a NEW GPSgateServer DSN automatically, didn't realise at first that I had to click the button next to it to do that ...

Brian

Return to “GpsGate Server - How to setup and use”