Page 1 of 1

impossible to configure custom url for rest api

Posted: Tue Sep 03, 2019 9:59 pm
by Inbox Reva
Hi
Explain please for today GGS version this instruction on changing rest api url working or not?
https://support.gpsgate.com/hc/en-us/articles/360014425594-How-to-change-the-comGpsGate-path-part-in-REST-URL

It seems everything is simple but for some reason it’s impossible to configure custom url for rest api according to this instruction

Thanks

Re: impossible to configure custom url for rest api

Posted: Wed Sep 04, 2019 11:42 am
by Greg
Hi,

The method described in https://support.gpsgate.com/hc/en-us/articles/360014425594-How-to-change-the-comGpsGate-path-part-in-REST-URL is valid.

If you still have issue, please post your GpsGate.Service.exe.config file here or email support and we can review it.
If you post it here, make sure to remove any sensitive information, such as passwords, from it before posting,

Re: impossible to configure custom url for rest api

Posted: Wed Sep 04, 2019 7:56 pm
by Inbox Reva
Hello
This is my file. Pay attention to the rest api key everything according to the instructions

but after restarting the service I get an error when call the resulting test URL

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Help me figure out what's wrong?

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <startup>
    <supportedRuntime version="v4.0" />
  </startup>
  <appSettings>
    <clear />
    <add key="NmeaPort" value="XXXXX" />
    <add key="UdpNmeaPort" value="XXXXX" />
    <add key="StarsNavUdpPort" value="XXXX" />
    <add key="StarsNavTcpPort" value="XXXX" />
    <add key="GlobalSatTcpPort" value="XXXX" />
    <add key="SmartPipeUdpPort" value="XXXXX" />
    <add key="SmartPipeTcpPort" value="XXXXX" />
    <add key="DatabaseType" value="XXX" />
[color=#FFFF00]    <add key="REST_URL_PATH" value="comUkrFleet" />[/color]
  </appSettings>
  <connectionStrings>
    <clear />
    <add name="ConnStr" connectionString="Dsn=GpsGateServer" />
  </connectionStrings>
  <runtime>
    <gcConcurrent enabled="true" />
    <gcServer enabled="true" />
  </runtime>
</configuration>

Re: impossible to configure custom url for rest api

Posted: Fri Sep 06, 2019 8:48 am
by Greg
The config file looks good. What is the expected resulting URL?

Re: impossible to configure custom url for rest api

Posted: Fri Sep 06, 2019 6:06 pm
by Inbox Reva
Hi
After making the changes in config, I expect to get the resulting URL https://map.ukrfleet.com/comUkrFleet/api/v.1/test
But this not work

Re: impossible to configure custom url for rest api

Posted: Mon Sep 09, 2019 3:23 pm
by Greg
Hi,

There might be a path conflict with something else running on your server.
Any errors in the NMEA error logs around the time you start/restart the Franson NMEA service?

Re: impossible to configure custom url for rest api

Posted: Mon Sep 09, 2019 7:07 pm
by Inbox Reva
Hi
There is error only like this

Code: Select all

2019-09-09 19:58:24.2032 | Error | 5 | MySQLOdbcConnector.CheckReconnect | OdbcNativeError = 1062 |

Code: Select all

2019-09-09 19:58:22.2501 | Error | 5 | TypeManager.RescanLoadableTypes | Error upgrading type GpsGate.NmeaPipe.FM2100DeviceDefinition
Can you tell me at the same time Why so many errors like this in log after every restart service?

Re: impossible to configure custom url for rest api

Posted: Tue Sep 10, 2019 9:01 am
by Greg
It's normal to have a few errors during the system startup.

If you send me the error logs I can take a look if there is anything related to the REST API path.
Please do a service restart before sending them and please email them to support: gpsgate.com/support