piter197
Posts: 826
Joined: Sun Jan 09, 2011 3:32 am

Slow TS100x rendering and memory problem

Tue Jan 23, 2018 5:24 am

Hi Support,

My GGS plugins all green: Updates.v5 ver 5.0.0.1163, Reporting ver 5.0.0.1087 and Time on Site 4.0.0.3923

I try to create TS1003 report for a VT application that have 270 vehicles with nearly 800 customer POIs. I notice that now rendering 1 day period for TS100x report really long for this VT application. It took 13 minutes and the GpsGate.Service (Franson NMEA service) that have < 1 GB memory size keep increasing until 2,7 GB memory size until it finish rendered the report then revert back to < 1GB memory size.

When I try to add more period like 5 days, rendering report take really long and finally GGS stop responding because of GpsGate.Service (Franson NMEA service) keep increasing its the size until no more free memory available.

Also while rendering report, I can not abort, if I click Abort button then I will get error message something like this:

Server Error in '/' Application
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

.....and so on....and so on.......

I also check Error log, it seems no related error message there.

Please help, is this normal or bug? is there any server setting that I need to change?
Best Regards,
piter197

Return to “GpsGate Server - How to setup and use”