Page 1 of 1

Unable to install Patch v4.0.0.5906

Posted: Wed Dec 13, 2017 3:22 pm
by Chris911
Hello,

I have been trying to install Patch v4.0.0.5906, but every time I try, it hangs up during the installation step, usually when copying files. (step 12/16).

My server is running Core 4.0.0.84 and patch v4.0.0.2190.

My server is running as a virtual machine so I took a copy of it, changed the server name and IP through the OS and have been trying to install the patches on the copy before putting them into production.

Is there a log that I can look at that would give more details about the problem? I've tried the install multiple times and it always hangs at the same step. I updated all of the Windows OS patches and updated the .NET framework to 4.62

Thanks
Chris

Re: Unable to install Patch v4.0.0.5906

Posted: Wed Dec 13, 2017 3:47 pm
by johan
If you server has not been upgraded since December 2016, please follow the steps below:

#1 Install .NET 4.6

https://www.microsoft.com/en-us/download/details.aspx?id=48130

#2 Activate ASP.NET 4.0

Please read under Step 3 in this guide:

http://forum.gpsgate.com/viewtopic.php?f=29&t=19575

#3 Make sure the Service runs under .NET 4

Edit the following two files:
C:\GpsGateServer\Franson NMEA Service\GpsGate.Service.exe.config
C:\GpsGateServer\Franson NMEA Service\Franson.SysMonitor.Service.exe.config

Add the following inside the <configuration> tag:

<startup>
<supportedRuntime version="v4.0" />
</startup>

After that is done, please start the Service again.