Page 1 of 1

Google Maps

Posted: Thu Oct 20, 2011 11:58 pm
by zeroingps
Good day,

Writing from Trinidad.

Since yesterday, reports have been giving trouble with addresses.

Instead of the address, it just show " Map " . Which shows the accurate location when you click on it.

Also on the map itself, if you use the request address on it, "no address found" for most of the map.

Need help asap.
Greatly appreciated

RE: Google Maps

Posted: Fri Oct 21, 2011 12:13 am
by johan
If you use a "free" Google maps key you only have 2500 address lookups (geocodings) per day. If you exceed that number you will get empty addresses in your reports.

We are about to release an affordable Google Maps option for GpsGate Server here:
http://gpsgate.com/purchase/google_maps

You also find other mapping and geocoding options here:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=10087

Regards,
Johan

GpsGate Support

RE: Google Maps

Posted: Fri Oct 21, 2011 5:12 pm
by zeroingps
Thanks for the reply Johan,

But I checked it today early and still no addresses.
It's not resetting or anything. Seems more like a permanent issue.

Is there any way I could test your Google Map option before I purchase it.
Once I know it'll solve the problem for sure I'll implement asap, as i need the reports to be working.

Regards,
Jason

RE: Google Maps

Posted: Fri Oct 21, 2011 5:23 pm
by johan
Please start installing the "LogFiles" plugin, and errors returned by the Google geocoding service can be seen under C:\GpsGateServer\ErrorLog more info:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=12886

If you use 3.0 reports, take a look here for how to re-process them:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=13659

You seems to use the older 2.3 reports, which will not require re-processing. Simply display the report again, and check for errors in the ErrorLog.

If you signup for our Google Maps option (which will go live Nov 1.) we will assist you to make it work.

Regards,
Johan

GpsGate Support

RE: Google Maps

Posted: Fri May 17, 2013 12:19 pm
by mdoble
I am having the same address problem.

If I use the request address on the map, the error message "no address found" is displayed for most of the map.

No addresses show up in the Vehicle info window, reports, or Alarm window.

I have a GpsGate-Google map key.

I have Live Address enabled.

I have not installed the Geocoder plug-in

How do I test if the system is using my key?

"Google" is selected under Geocoder.
[ADDRESS] is what shows up in the Geocoding address format box.

under Usage on the Maps tab, I show 0 for the Total.

RE: Google Maps

Posted: Fri May 17, 2013 12:23 pm
by johan
Check in the error log if you have any errors fpor the time period. You find the error log under C:\GpsGateServer\ErrorLog

Regards,
Johan

GpsGate Support

RE: Google Maps

Posted: Sat May 18, 2013 5:34 am
by mdoble
Did not find any fpor errors. Below are the last few errors after I tried to find an address.

2013-05-17 18:27:31.0008 | Error | 10 | BOBase.m_FindBoTypes | TypeLoadException Message = Could not load file or assembly 'GpsGate.Cleanup, Version=3.0.0.2583, Culture=neutral, PublicKeyToken=9e4b59507d3e1a4f' or one of its dependencies. The system cannot find the file specified. |

2013-05-17 18:27:31.0008 | Error | 10 | BOBase.m_FindBoTypes | Exception Finding ILoadables trying to load = C:\GpsGateServer\IIS\bin\GpsGate.Reporting.v3.Cleanup.dll |

2013-05-17 18:27:40.9553 | Error | 13 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | Error response from geocode.gpsgate.com Request: http://geocode.gpsgate.com/Services/Geo ... anguage=en |

2013-05-17 18:27:41.1063 | Error | 13 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | <Type>GpsGate.Geocode.Service.GeocodeException</Type><Message>Invalid key</Message> |

2013-05-17 18:28:03.9286 | Error | 11 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | Error response from geocode.gpsgate.com Request: http://geocode.gpsgate.com/Services/Geo ... anguage=en |

2013-05-17 18:28:03.9286 | Error | 11 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | <Type>GpsGate.Geocode.Service.GeocodeException</Type><Message>Invalid key</Message> |

2013-05-17 18:28:58.7748 | Error | 9 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | Error response from geocode.gpsgate.com Request: http://geocode.gpsgate.com/Services/Geo ... anguage=en |

2013-05-17 18:28:58.7748 | Error | 9 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | <Type>GpsGate.Geocode.Service.GeocodeException</Type><Message>Invalid key</Message> |

2013-05-17 18:29:18.2039 | Error | 8 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | Error response from geocode.gpsgate.com Request: http://geocode.gpsgate.com/Services/Geo ... anguage=en |

2013-05-17 18:29:18.2039 | Error | 8 | GoogleGeocoderProvider.m_GpsGateRetailReverseGeocodeRequest | <Type>GpsGate.Geocode.Service.GeocodeException</Type><Message>Invalid key</Message> |

Thanks for your help,

Mike

RE: Google Maps

Posted: Sat May 18, 2013 6:33 am
by mdoble
I was able to fix my map problem after I saw the error message Invalid key, I rechecked my map key and found a space at the end of the map key.