User avatar
johan
GpsGate
Posts: 14988
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

GUIDE: GpsGate can only be reached from localhost

Thu Jul 28, 2011 10:01 pm

Note: for an updated version of this and other articles, we recommend you to check our knowledge base here

SYMPTOM

You run Windows XP/Vista/7 and can only reach GpsGate's web interface using http://localhost/... in a browser, and not from a remote computer.

CAUSE

When GpsGate Server was installed the install Wizard noticed that you had not enabled IIS on your computer. Therefor IIS Express was installed. By default IIS Express will only be accessible from localhost.

SOLUTION

Open the file "C:\GpsGateServer\IIS\iisexpress_applicationhost.config" in a text editor. (If this file does not exist, then IIS Express is not used, and this guide is not what you need!)

Search for the <bindings> change it to the following

Code: Select all

<bindings>
    <binding protocol="http" bindingInformation="*:80:" /> 
</bindings>
When this is done you need to restart IIS Express. You do this under Windows Control Panel -> Administrative Tools -> Services. Right click on "Franson IISExpress Service" and select "Restart".

Now you should be able to access GpsGate's web interface from remote computers!

Regards,
Johan

GpsGate Support

Dirdnav
Posts: 94
Joined: Sat Jun 11, 2011 3:28 pm

RE: GUIDE: GpsGate can only be reached from localhost

Tue Dec 20, 2011 11:15 am

Hi Sir,

I have had dedicated IP on my hosting(hostmonster) server and I want testing online GpsGate server,

Please advise.

Regards,
Vandrid

brumas
Posts: 11
Joined: Fri Jul 19, 2013 9:52 am
Location: Canada

RE: GUIDE: GpsGate can only be reached from localhost

Sat Apr 12, 2014 7:53 pm

Hi,

I have been trying this several days but so far I can't access the GpsGate from other computer than the server itself. Not even computers in the same LAN.

The address I'm using to access my GpsGate Server is mypublicip/gpsgateserver

* On the Router side:
1. I already forward the ports 30175 and 80 (and others for the trackers in use) to both TCP and UDP.
2. The firewall is setup for "NAT only" and has WAN Ping block enable.
3. and I reserved the local IP address of the server machine on DHCP reservation

* On the Server:
1. I reserved the local IP address to this machine (the same IP address that I forward the ports on the router) under protocol version 4 properties of the connection properties
2. before trying to create a new rule on windows firewall, I just turn off the firewall, so i guess with the firewall disable nothing should be blocked there.

* The file "C:\GpsGateServer\IIS\iisexpress_applicationhost.config" has the bindings tag exactly like you said it should be, twice already.

* Using the link to test firewall ports (http://test.gpsgate.com/FirewallTest/index.aspx)
the results came like I show below
TEST 1
Public IP: my public IP (the same as shown on "localhos/gpsgateserver/siteadmin/siteadmin.aspx)
Port: 80

Result:
TCP status: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond MyPublicIP:80
UDP status: Send OK, please check the Terminal!

TEST 2
Public IP: my public IP
Port: 30175

Result:
TCP status: Send OK, please check the Terminal!
UDP status: Send OK, please check the Terminal!

So apparently if I can see a problem, it seems to be port 80 on my first test

So what would you advise me to do?

brumas
Posts: 11
Joined: Fri Jul 19, 2013 9:52 am
Location: Canada

RE: GUIDE: GpsGate can only be reached from localhost

Mon Apr 14, 2014 7:27 am

I just call the support service of my network and they told me that my router has several ports blocked including port 80 so it seems i can't use port 80 for my web server. They gave the option to go to a business line and then I will have all ports open. but they way more expensive.

Is there a way I can configure a different port to the web server?

oliton
Posts: 12
Joined: Fri Apr 18, 2014 5:12 pm

RE: GUIDE: GpsGate can only be reached from localhost

Sat Apr 19, 2014 4:32 pm

Hello,

I have a server working well with my tracking devices. I'd like to access to my server from another computer on my LAN or from internet, but it is not working:

I deactivate the firewall of Windows and of the router

I added NAT/PAT rules on my router so that the server is accessible from internet: UDP and TCP for port (8008 / 8081 / 80 / 30175)

I checked the configuration file of my IISExpress (iisexpress_applicationhost.config):
<bindings>
<binding protocol="http" bindingInformation="*:8081:" />
</bindings>

When I connect locally to my server I use http://localhost:8081/GpsGateServer/Sit ... Index.aspx, so to access it on internet I used: http://IPOfMyRouter:8081/GpsGateServer/ ... Index.aspx but that doesn't work (the same with the ports 8008 / 80 / 30175)

I also tried the configuration file with:
<bindings>
<binding protocol="http" bindingInformation="*:80:" />
</bindings>

When I use http://test.gpsgate.com/FirewallTest/index.aspx I have the following messages on port 30175 and 8081:
TCP status: Send OK, please check the Terminal!
UDP status: Send OK, please check the Terminal! (I have and Unknow connection only with 30175)

When I use http://test.gpsgate.com/FirewallTest/index.aspx I have the following messages on port 80:
TCP status: No connection could be made because the target machine actively refused it IPOfMyRouter:80
UDP status: Send OK, please check the Terminal!

What can I do / test to make this working ? Thank you.

oliton
Posts: 12
Joined: Fri Apr 18, 2014 5:12 pm

RE: GUIDE: GpsGate can only be reached from localhost

Sat Apr 19, 2014 9:26 pm

I figure out how to solve my problem. When I first installed GpsGate Server, I had Skype installed and using the port 80, so GpsGate Server proposed the port 8081. But I couldn't access it from internet.

I made a new installation after having configured Skype to work on another port than 80. So GpsGate Server was configured on the port 80. And then my GpsGate Server was accessible from internet.

So if you installed GpsGate Server, make sure to do it with the port 80. Maybe you can do it on another port, but there's something to configure so that it is accessible from internet but I couldn't figure out what to do.

miguel3m
Posts: 2
Joined: Thu Feb 05, 2015 7:37 am
Location: Mexico

RE: GUIDE: GpsGate can only be reached from localhost

Sun Feb 08, 2015 2:20 am

i have the same configuration on "C:\GpsGateServer\IIS\iisexpress_applicationhost.config" :

<bindings>
<binding protocol="http" bindingInformation="*:80:" />
</bindings>

i can access on my LAN, but on remote pc/smartphone, i only see the Login page, when i put my user and password, says: "Invalid Login Details".

I already see my Devices (meitrack) working.
My Open ports are:
WAN - LAN
8008 8008
30175 30175
5505 5505
8500 8500
82 80

My Solution:
change the external port "82" to "80"
and now is working for remote access.

caronmap
Posts: 5
Joined: Sun Mar 26, 2017 11:22 pm

Re: GUIDE: GpsGate can only be reached from localhost

Sun Mar 26, 2017 11:52 pm

Hello, Yesterday I was able to setup the GpsGate application. Just I need some information to finalize at least my final configuration to be able to access it correctly. Story starts that my gps gate is installed under:

*Router (Static IP) > LAN cable connected to QNAP (192.168.0.100) > In QNAP I have installed Virtual Server *windows server 2012 (192.168.0.105) is installed GpsGate application.

My QNAP uses external port 80 to internal 80 in QNAP to access a web pages let say wordpress site. So all requests outside localhost is redirected to 0.100:80 (QNAP web folder). I read in a forums that gpsgateserver uses port 80 as well. Ok, so for that I made external port 82 forwarding to Virtual Machine 80 *192.168.0.105:80.

From my localhost/gpsgateserver everything is working. I see login screen I'm able to login.

1) Problem starting then first I write http://x.x.x.x:82 -> it redirects me to windows server 2012 internet information services blue screen. How to change or delete that blue screen ?

2) If I enter http://x.x.x.x:82/gpsgateserver -> the login screen appear so I can access it. But then I type username ^ password and click login > choose application window appear I select: siteadministration application and click login: then I have a problem:
-----------------------------------------------------------------------------------------------
http://x.x.x.x/gpsgateserver/SiteAdmin/ ... px?appid=1
-----------------------------------------------------------------------------------------------

Not Found

The requested URL /gpsgateserver/SiteAdmin/Index.aspx was not found on this server.

Apache Server at x.x.x.x Port 80
---------------------------------------------------------------------------------------------------------------------------------

so I should add port 82 manualy to the adress and change http://x.x.x.x/gpsgateserver/SiteAdmin/ ... px?appid=1 to [url]http://x.x.x.x:82/gpsgateserver/SiteAdmin/Index.aspx?appid=1[/url]

then the application appear.
-------------------------------------------------------------------------------------------------------------------------------

3) In localhost then I got to plugins I'm able to see all the plugins. But then I connected from external to the application, and go to plugins I see the page but no plugins at all. It says under Status Error no plugins are loaded but gpsgate application visible normally.

4) Then I enter http://x.x.x.x/gpsgateserver on my Samsung Galaxy S7 it redirects me to http://x.x.x.x:82/gpsgateserver/m/index.html#/login I entering my username and password and it shows me: login failed with code:

if I switch it to Desktop version then with the same username and password it's connected OK.

Could someone pleas explain me and help with the correct configuration, where I should change the settings. Thank you in advance. :)
Last edited by caronmap on Wed Jun 07, 2017 10:31 am, edited 1 time in total.

User avatar
david
GpsGate
Posts: 11
Joined: Wed Mar 30, 2016 4:10 pm
Location: Sweden

Re: GUIDE: GpsGate can only be reached from localhost

Fri Mar 31, 2017 9:35 am

Hi,
Let's start with point 1 and 2. Please try the following steps:

step1: redirect 77.79.35.135:82 -> 192.168.0.105:82

step2: in C:\GpsGateServer\IIS\ iisexpress_applicationhost. config, change:
<bindings>
<binding protocol="http" bindingInformation="*:82:" />
</bindings>

step3: When this is done you need to restart IIS Express. You do this under Windows Control Panel -> Administrative Tools -> Services. Right click on "Franson IISExpress Service" and select "Restart".

step4: test http://77.79.35.135:82/ gpsgateserver

Best Regards,
David
David

Return to “GpsGate Server - How to setup and use”