piter197
Posts: 830
Joined: Sun Jan 09, 2011 3:32 am

RE: Geofence Event Rule Not Notify Correctly

Wed Jun 08, 2011 2:13 am

I got problem with both kind "inside" and "outside" rule. Before this problem occured, yes the first time outside geofence event rule activated the [GEOFENCE_NAME] blank then after that normal. But after this problem occur, both "inside" and "outside" rule notify with [GEOFENCE_NAME] blank.

Thank you.


Best Regards,

Piter197

husky92
Posts: 362
Joined: Wed Mar 31, 2010 2:08 am
Location: Norway

RE: Geofence Event Rule Not Notify Correctly

Wed Mar 13, 2013 4:54 pm

Hi!

I have a problem with blank value in [GEOFENCE_NAME] parameter used in event rule notifications. Is this still a known problem?

I recently created a new geofenche while the GPS devices were inside the area. The event rule for outside geofence was created previously, but when the first GPS device left the area, the notifications (SMS and email) contain a blank value for [GEOFENCE_NAME].

Thank you!

Best Regards,

User avatar
johan
GpsGate
Posts: 14981
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Geofence Event Rule Not Notify Correctly

Wed Mar 13, 2013 5:46 pm

The device must have at least one position update inside the geofence to know which geofence it is leaving.

To draw a geofence over a device will not trigger any inside rules until a new position is sent to the server from the device.

And to draw a geofence over a device will require at least one position update inside the geofence after the fence was drawn to include understand which fence it was leaving.

Regards,
Johan

GpsGate Support

husky92
Posts: 362
Joined: Wed Mar 31, 2010 2:08 am
Location: Norway

RE: Geofence Event Rule Not Notify Correctly

Wed Mar 13, 2013 9:29 pm

Thank you for the explanation! I will test and verify your explanation. Is there a way to avoid this problem when creating new geofences when the GPS units are still inside?

Thank you!

Return to “GpsGate Server - How to setup and use”