keke
Posts: 2
Joined: Sat May 28, 2011 3:42 pm
Location: Finland

Failed to "Send settings to device"

Sat May 28, 2011 5:35 pm

Version: 3.0.0.2583

Settings for SMS Proxy are done, and Proxy is active. Service / Providers has HttpMessageProvider created, and it's running and it's DefaultProvider. It is also tested, I can send SMS in Terminal, and Settings / SMS / Send Test SMS works. Receiving of SMS also works.

When trying to "Send settings to device", SMS is sent to device at the first stage. The message is "W000000,010,12345678". Message is received by device, and it answers "Set SIM Ok/12345678". The response is received as described in topic.asp?TOPIC_ID=11344, like: /Message/?username=username&pw=pw&clientaddress=%2B358401234567&message=Set%20SIM%20Ok%2F12345678&transport=sms&clientdate=270511&clienttime=142036

After the response is received by GpsGate, result is "Error" and status is:

Command: GprsSetupVTandGT
Latest error: No such host is known
Last activity: (timestamp)
State: PermanentFailure
Description: Set device ID

What does the "No such host is known" mean and what kind of failures or missing settings may cause that?

In System Tools / Terminal messages are shown like:

[2011-05-28 14:38:25] (+358401234567/Meiligao/sms) Client: This SMS is for testing.
[2011-05-28 14:34:19] (+358401234567/Meiligao/sms) Client: Set SIM Ok/12345678
[2011-05-28 14:33:56] (+358401234567/Meiligao/sms) Server: W000000,010,12345678

System Tools / Queue viewer:

GprsSetupVTandGT 1 6 Set device ID Device username PermanentFailure Out - 2011-05-28 11:33:56 2011-05-28 11:34:19 1

Arguments:
1)$ROUTE,device,4,sms*34
2)$FRCMD,,_GprsSettings,Nmea,4*01
3)$FRVAL,DeviceImei,12345678*57
4)$FRVAL,DevicePhoneNumber,+358401234567*28
5)$FRVAL,GprsApn,internet.provider*03
6)$FRVAL,ProtocolHostname,http://my.host.com/application/*66

On another server incoming messages are not shown in the queue, but issue is the same.

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Sat May 28, 2011 6:03 pm

Check SiteAdmin -> Settings -> SMS -> Server Hostname

Make sure you only write the hostname e.g. myserver.com (or the public IP address to the server). Do not write the web URL.

In your case you have probably written "http://my.host.com/application/" in this field, but it should be "my.host.com".

Regards,
Johan

GpsGate Support

keke
Posts: 2
Joined: Sat May 28, 2011 3:42 pm
Location: Finland

RE: Failed to "Send settings to device"

Sat May 28, 2011 7:24 pm

Thank you very much for the fast answer!

Yes, in that field I had the URL of server which sends and receives SMS. With IP of GpsGate server sending of settings works.

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Tue Jan 24, 2012 5:51 pm

i have some problem related to this
when i send the command "send setting to device " via SMS for teltonika 4200 the status shows 1/11 and pending while i get the SMS back from the device that a new parameter "SET" as ok
while the GGS does not continue to next command, it seems that i cant link the return SMS from devices to the server, can any one tell me how to do this?, or how to make the GGS continue sending the settings ?

Version: 3.0.0.2583, XP

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Tue Jan 24, 2012 6:01 pm

Use the "Terminal" to monitor data traffic between server and device:
http://forum.gpsgate.com/topic.asp?TOPIC_ID=10740

Can you see the incoming SMS in the Terminal?

Regards,
Johan

GpsGate Support

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Tue Jan 24, 2012 6:30 pm

no back SMS on terminal i have aborted the first attempt and again sent setting to device with no SMS back on terminal, in both cases the SMS is only in the mobile itself

note i have cleared some numbers from IMEI and SIM ,


[2012-01-24 15:39:59] (+96277542xxx/Teltonika/sms) Disconnect
[2012-01-24 15:30:45] (+96277542xxx/Teltonika/sms) Server: setparam 3245 79.134.129.11
[2012-01-24 15:30:45] (+96277542xxxx/Teltonika/sms) Login: fm4200_40/3543300307zzzzz
[2012-01-24 15:30:45] (+96277542xxxx/Teltonika/sms) Connect
[2012-01-24 15:19:59] (+96277542xxx/Teltonika/sms) Disconnect
[2012-01-24 15:12:51] (+96277542xxx/Teltonika/sms) Server: setparam 3245 79.134.129.11
[2012-01-24 15:12:51] (+96277542xxx/Teltonika/sms) Login: fm4200_40/3543300307zzzzz
[2012-01-24 15:12:51] (+96277542xxx/Teltonika/sms) Connect

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Tue Jan 24, 2012 6:40 pm

Maybe you should try a "manual" setup as described here:
http://gpsgate.com/videos?movie=L0AIpcUGMSY

Regards,
Johan

GpsGate Support

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 12:57 pm

that is done already , the idea is not to configure FM4200 right now i can send setting via my mobile , i want to learn how to configure the SMS proxy to receive incoming SMS from devices , this might help in control and taking position as well, not only configuration,it's about automating the tracking solution , the idea is to get the best out from GPS gate

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 2:51 pm

Check in the Terminal if the proxy username is connected to the server. It should send a "_Ping" every 1 minute.

Regards,
Johan

GpsGate Support

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 4:12 pm

yes it is pinging like below every 3 min
[2012-01-25 14:14:33] (127.0.0.1:1085/GpsGate/tcp) Server: $FRRET,amayiri,_Ping,Inline*5B[0x0D][0x0A]
[2012-01-25 14:14:33] (127.0.0.1:1085/GpsGate/tcp) Client: $FRCMD,,_Ping,Nmea,0*26[0x0D][0x0A]
[2012-01-25 14:11:33] (127.0.0.1:1085/GpsGate/tcp) Server: $FRRET,amayiri,_Ping,Inline*5B[0x0D][0x0A]
[2012-01-25 14:11:33] (127.0.0.1:1085/GpsGate/tcp) Client: $FRCMD,,_Ping,Nmea,0*26[0x0D][0x0A]
[2012-01-25 14:08:33] (127.0.0.1:1085/GpsGate/tcp) Server: $FRRET,amayiri,_Ping,Inline*5B[0x0D][0x0A]
[2012-01-25 14:08:33] (127.0.0.1:1085/GpsGate/tcp) Client: $FRCMD,,_Ping,Nmea,0*26[0x0D][0x0A]
[2012-01-25 14:05:33] (127.0.0.1:1085/GpsGate/tcp) Server: $FRRET,amayiri,_Ping,Inline*5B[0x0D][0x0A]
[2012-01-25 14:05:33] (127.0.0.1:1085/GpsGate/tcp) Client: $FRCMD,,_Ping,Nmea,0*26[0x0D][0x0A]

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 4:30 pm

Great, then we know GpsGate SMS Proxy is setup properly and connected to the server.


Use the Test function under SiteAdmin -> Settings -> SMS to verify if you can send an SMS to your mobile phone.


Regards,
Johan

GpsGate Support

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 7:39 pm

i have made the test , it is ok
when i change the parameter one by one using terminal the SMS is sent correctly but the reply with success from tracker is sent back to the mobile attached to SMS proxy, i think when GGS dont receive SMS from tracker GGS will stop the "send setting to device " from continue am i right here??
i think i should make some setting to make GGS receive the incoming SMS from tracker device instead of the mobile attached to SMS proxy this exactly what i want to learn ,

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Wed Jan 25, 2012 7:46 pm

Try to send an SMS from your mobile phone to the proxy phone.

Can you see this SMS coming in in the Terminal (possibly under "Unknown Connections")?

Please also check the log file you find in the same folder as "GpsGate SMS Proxy", can you see the SMS coming in there? Can you see any error messages?

Regards,
Johan

GpsGate Support

Hus
Posts: 30
Joined: Thu Jan 05, 2012 9:22 pm

RE: Failed to "Send settings to device"

Thu Jan 26, 2012 2:59 pm

i did but not received neither in the unknown connections nor in the proxy username "where it pings every min"

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Failed to "Send settings to device"

Thu Jan 26, 2012 3:02 pm

Please also check the log file you find in the same folder as "GpsGate SMS Proxy", can you see the SMS coming in there? Can you see any error messages?

Regards,
Johan

GpsGate Support

Return to “GpsGate Server - How to setup and use”