Page 1 of 1

Virtual Ports on Windows 8.1 not working

Posted: Sun Oct 20, 2013 10:47 am
by tmaesing
Hi,

I have updated my Tablet to Windows 8.1 and I now get a
[5] Failed to create virtual serial port
error, with Windows 8 all was working. Is there a solution?
I have tried to reinstall GPSGates but it does not help.

Best regards
Thomas

PS
Will the location api be supported to use internal gps without com ports?

RE: Virtual Ports on Windows 8.1 not working

Posted: Wed Oct 23, 2013 11:52 am
by tmaesing
Hi,

switching off secure boot helps.

Best regards
Thomas

RE: Virtual Ports on Windows 8.1 not working

Posted: Sun Nov 01, 2015 6:55 pm
by patchdoc
I am having the same difficulty with GpsGate (v2.6.0.340) and with my Garmin Oregon 650t. GpsGate says it is "Running OK! GPS data with valid position". However all the COM ports state "[5] Failed to create virtual serial port". I am using Windows 10 Pro, 64-bit. I have GpsGate running in Administrator mode, and Secure Boot is off. Is it possible all the low numbered COM ports are already assigned? Device Manager does not show any COM port devices. Any suggestions?





I notice in my Windows 10 Device Manager under Events, Information, it reads, "Device USB\VID_091E&PID_0003\5&1003806&0&1 requires further installation."



Is there a problem with the Garmin latest version USB driver (v. 2.3.1.0)?

Re: Virtual Ports on Windows 8.1 not working

Posted: Mon Nov 06, 2017 3:01 pm
by bluediesel
I have the same problem but it is new. For the past couple of years I have had GPS gate working fairly well, some random problems here and there but managed to work around them. Today I have the failure to create serial port. Yesterday when I hibernated by windows 8.1 tablet I forgot to close GPSgate and forgot to close nRoute, and today GPSgate works but cannot create virtual ports, all of the fail from port 1 to port 10. Anyone solve this yet? regards, Rob

Re: Virtual Ports on Windows 8.1 not working

Posted: Wed Nov 08, 2017 11:53 am
by bluediesel
Dear Forum,
My problem with "failure to create virtual port" has been solved. It was suggested to me to try uninstalling GPSgate and reinstalling the software. This indeed did work the virtual ports were reset and now I can create them again. regards, Rob