Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: ServiceStream.BeginRead problem

Fri May 22, 2009 12:06 pm

1. I don't understand this question. The whole purpose of ServiceStreams are to get bytes from different devices.

2. I don't understand this question either. Each new BlueTools version has been tested before released.

3. BlueTools has been only been tested on Windows XP as far as I know, but has been reported to work on Windows Vista as well.


Regards,
Jonas

ravilolam
Posts: 15
Joined: Mon Apr 27, 2009 9:03 pm
Location: India

RE: ServiceStream.BeginRead problem

Sat May 23, 2009 4:23 pm

Originally posted by Jonas

1. I don't understand this question. The whole purpose of ServiceStreams are to get bytes from different devices.

2. I don't understand this question either. Each new BlueTools version has been tested before released.

3. BlueTools has been only been tested on Windows XP as far as I know, but has been reported to work on Windows Vista as well.


Regards,
Jonas


Dear Jonas,

Everything is working fine, but i am not able to make a connection with the remote device.

Could you please help me.

Is there any other way to connect to remote device except the way used in "FindAndConnect" sample.

Thanks & Regards
Ravikumar Lolam

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: ServiceStream.BeginRead problem

Mon May 25, 2009 9:21 am

You can connect to a device via ConnectDevice as well, as described in the ObexFTP sample, but it won't make any difference. If the FindAndConnect way doesn't work, the other way won't work either.

Regards,
Jonas

ravilolam
Posts: 15
Joined: Mon Apr 27, 2009 9:03 pm
Location: India

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 4:48 pm

Originally posted by Jonas

You can connect to a device via ConnectDevice as well, as described in the ObexFTP sample, but it won't make any difference. If the FindAndConnect way doesn't work, the other way won't work either.

Regards,
Jonas


Dear Jonas,

I had a try with all the samples. Every application is working fine. But the FindAndConnect application is not working fully.

I mean the following events are working fine.


Device Discovery
Service Discovery
Boding/Pairing Devices


The following event is not working in FindAndConnect application


serviceList_SelectedIndexChanged()


Can you check it once and let me know what will be the problem.

I am working with Desktop Framework 2.0.

Thanks & Regards
Ravikumar Lolam

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 5:40 pm

There is no magic in how this works. Look at one of the other samples if something is different there.
The ObexFTPClient sample for example is using almost exactly the same techniques.

Regards,
Jonas

ravilolam
Posts: 15
Joined: Mon Apr 27, 2009 9:03 pm
Location: India

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 6:59 pm

Originally posted by Jonas

There is no magic in how this works. Look at one of the other samples if something is different there.
The ObexFTPClient sample for example is using almost exactly the same techniques.

Regards,
Jonas


Dear Jonas,

I agree with you. But whenever i select a service from the service list then it should return some bytes from remote device right?

But in my case, if i click on a service in the service list then it is not responding for a long time.

I have tested the application in debug mode, the control never been entered into the readCallback method.

I have also tested with three more laptops, but facing the same situation on all the machines.

<font color="red">Why would this causing problems?</font id="red">

<font color="red">What could be the reason?</font id="red">

But the ObexFTPClient is working fine without any errors.

<font color="red">What do you think about this error?</font id="red">



Thanks & Regards
Ravikumar Lolam

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 7:06 pm

I have no idea what could be causing the problem, as I've stated before I've never encountered this error.

I can only reply again that I suggest that you look at the difference between the ObexFTPClient and the FindAndConnect and determines the difference between them. But again, both samples have always worked in the past.

Regards,
Jonas

ravilolam
Posts: 15
Joined: Mon Apr 27, 2009 9:03 pm
Location: India

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 7:50 pm

Originally posted by Jonas

I have no idea what could be causing the problem, as I've stated before I've never encountered this error.

I can only reply again that I suggest that you look at the difference between the ObexFTPClient and the FindAndConnect and determines the difference between them. But again, both samples have always worked in the past.

Regards,
Jonas


Dear Jonas,

I am extremely sorry for disturbing you.

Could you please suggest me to find a solution for my intention.

My Intention is :

I want to connect to PAN (Personal Area Networking) service.

I am requesting you to give me an idea.


Thanks & Regards
Ravikumar Lolam

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: ServiceStream.BeginRead problem

Thu May 28, 2009 7:52 pm

My suggestion stands, try building your sample on top of the Obex FTP Client. Remove the parts not valid for your project.
I have no other ideas on how to help you.

Regards,
Jonas

Return to “BlueTools”