henryhui
Posts: 23
Joined: Sat Mar 04, 2006 9:11 am

Connection Failed

Tue Mar 28, 2006 8:14 pm

Hi,

I have 2 Pocket PC, Dell X50v (Windows Mobile 2003) and Dell X51 (Windows Mobile 5).

I installed "Find And Connect" on X50v and "Simple Service" on X51. X50v can discover X51 successfully, but while i try to create a session, it failed.

I have also tried to install "Find And Connect" on X51 and "Simple Service" on X50v. Session can be create and text also can be sent. this makes me don't know how to fix this problem.

As i know that, Windows Mobile 2003 is using WinComm stack, while Windows Mobile 5 is using Micosoft stack, is it the problem causing them can't communicate?

Thanks

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Connection Failed

Wed Mar 29, 2006 11:16 am

If you haven't modified the Simple Service sample any it will attempt to make a SerialPort service when you start it. If you try creating some other service than a serial port does it work then?

Do this you change this line:

m_service = new LocalService(ServiceType.SerialPort, "SimpleService", "Sample");

to another ServiceType.

Regards,
Jonas
Franson Support

henryhui
Posts: 23
Joined: Sat Mar 04, 2006 9:11 am

RE: Connection Failed

Thu Mar 30, 2006 10:27 am

I have tried to use RFCOMM, but the same as SerialPort service, i can't open a session.

I want to simply create a session for send/receive strings, is it suitable for me to use RFCOMM?

Thanks

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Connection Failed

Thu Mar 30, 2006 12:44 pm

RFCOMM can be used to transfer text strings yes.

Have you tried other ServiceTypes, though inappropriate for text messages, that you can connect to?

Regards,
Jonas
Franson Support

Return to “BlueTools”