dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

Axim x51 License Issue

Sun Jan 29, 2006 9:02 pm

I copied the license I received.
Built the app

When I attempt to run the app, I get:

> An unexpected error has occurred in FindAndConnect.exe ... details:
>
> Exception
> BlueTools.dll not installed. Please visit franson.com/bluetootls for mor
> info.
> at Franson.BlueTools.License..ctor()
> at FindAndConnect.MainForm..ctor()
> at FindAndConnect.MainForm.Main()
>
> I installed the setup.exe from the BlueToolsSDK. When I open the
> FindAndConnect solution in VS2005 Pro and try to build, I get many build
> errors. I looked in the References and do not see anything new to add (
> from Franson ). I assumed I had to add Franson.BlueTools.200.CF.dll from
> the recent tab and in the dotNetcf200 folder.

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Axim x51 License Issue

Mon Jan 30, 2006 11:56 am

Please follow the steps in the developer's guide on how to get started:

http://franson.com/bluetools/guide.asp?section=csNetCfSetup&platform=netcf

You should read section "4." carefully.

4. You need to install some native DLLs
BlueTools.dll.
BlueToolsMS.dll (Microsoft stack support).
BlueToolsWC.dll (WidComm stack support).
BlueToolsWC150.dll (Extended WidComm stack support).

All those DLLs should be copied to \Windows on your device. The easiest way to do this is to transfer BlueTools.arm.CAB file to the device and run it. Or you can copy the DLLs to the same directory as your application (EXE).
Note! ARM and XScale are the same type of processor. If you need DLLs for another processor, please contact us.

You find the native DLLs and .NET 1.0 resources under:
Start -> Program -> Franson BlueTools SDK -> .NET Compact Framework 1.0 -> Samples & Assemblies
And .NET 2.0 samples and assemblies under:
Start -> Program -> Franson BlueTools SDK -> .NET Compact Framework 2.0 -> Samples & Assemblies


Regards,
Johan

Franson Support

dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

RE: Axim x51 License Issue

Tue Jan 31, 2006 9:09 am

Johan -

I uninstalled, rebooted, reinstalled the BlueTools and have exactly the same issues.

I printed and read the instructions EXACTLY ! I placed all the dlls in \Windows of the Axim PDA ( even though the instruction say to copy or use the CAB, the WidCOmm stack/dlls which Dell does not use ).

An unexpected error has occurred in FindAndConnect.exe ... details:

Error
FindAndCOnnect.exe
Exception
BlueTools.dll not installed. Please visit franson.com/bluetootls for more info.

at Franson.BlueTools.License..ctor()
at FindAndConnect.MainForm..ctor()
at FindAndConnect.MainForm.Main()

after I pressed Quit, I also get:

Error
An unexpected error has occurred in FindAndConnect.exe.
Select Quit and the restart this program, or select Details for more information.
Can't Find PInvoke DLL 'BlueTools.dll'

Error
FindAndConnect.exe
MissingMethodException
Can't find PInvoke DLL 'BlueTools.dll' .

at Franson.BlueTools.License.Finalize()



Any ideas?

It builds fine. I added the Reference:
Franson.BlueTools.200.CF

located in the
C:\Program Files\Franson\BlueTools SDK\dotNetcf200 folder.

I rebooted and tested the app and same problem.

I have the dlls in both the \Windows forlder and the folder I installed the app in. Rebooted, same problem.

I installed the BlueTools.arm.CAB and ran it, rebooted, ran the app and SAME PROBLEM.

Please help!

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Axim x51 License Issue

Tue Jan 31, 2006 1:33 pm

The error message you are referring to states that the BlueTools.dll can't be found. Can you confirm that all four dll:s are in the folder MyDevice\Program Files\FindAndConnect?

The files needed for BlueTools are (as stated above):
BlueTools.dll.
BlueToolsMS.dll (Microsoft stack support).
BlueToolsWC.dll (WidComm stack support).
BlueToolsWC150.dll (Extended WidComm stack support).

Have you tried running the program directly from the x51 instead of running it through deployment in Visual Studio 2005?


Regards,
Jonas
Franson Support

dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

RE: Axim x51 License Issue

Tue Jan 31, 2006 2:19 pm

Johan -
Yes to both questions.

The exe is at the path you describe:
My Device\Program Files\findandconnect\FindAndConnect.exe

along with the dlls and franson.bluetools.200.cf.dll

Any other ideas?

D

dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

RE: Axim x51 License Issue

Tue Jan 31, 2006 2:22 pm

Jonas,

Sorry, my last reply I thought I was responding to Johan.

Any, any assistance would greatly be appreciated.

Thank you.
David

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Axim x51 License Issue

Tue Jan 31, 2006 2:54 pm

I'll contact you off the forum to try to resolve this.

Regards,
Jonas
Franson Support

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Axim x51 License Issue

Tue Jan 31, 2006 5:32 pm

Solution to problem:

Make sure you are using the Pocket PC dll files. The problem mentioned above was caused by attempting to use the Windows Desktop version of BlueTools on Pocket PC.

We have updated the installation instructions so it will be easier to understand how to install and find the correct files.
http://franson.com/bluetools/guide.asp?section=csNetCfSetup&platform=netcf

Regards,
Jonas
Franson Support

dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

RE: Axim x51 License Issue

Tue Jan 31, 2006 7:31 pm

The documentation needs clarification.

The location of the cab file or the DLLs is different than indicated.

Actual location:
C:\Program Files\Franson\BlueTools SDK\dotNetcf\wince420\arm

from the install process.

Documentation location:
\Program Files\Franson BlueTools SDK\.NET Compact Framework 2.0\Samples & Assemblies

Perhaps just a little more tweeking and tuning of the documentation is in order.


Thanks to Jonas, we figured out what was happening and his efforts have been greatly appreciated.

Thanks Jonas.

Sincerely,
David

User avatar
johan
GpsGate
Posts: 15224
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: Axim x51 License Issue

Tue Jan 31, 2006 9:06 pm

If you read the docs, it says

Start -> Program -> Franson BlueTools SDK -> .NET Compact Framework 1.0 -> Samples & Assemblies

Meaning you click on "Start" button in the bottom left corner of the Windows. Then you open the "Program" folder. Then...

Regards,
Johan

Franson Support

dgretlein
Posts: 13
Joined: Tue Jan 24, 2006 6:39 pm
Location: USA
Contact: Website

RE: Axim x51 License Issue

Wed Feb 01, 2006 10:30 am

Jonas -

Are you, or Franson support team, aware there is a device ( Dell Axim x51 ) driver and WM5 issue?

It appears this is the culprit of the problem and why I cannot receive data.

I have been looking at Dells site support and forums for the x51 and found there is indeed a problem with the Bluetooth firmware and in particular running WM5.

http://forums.us.dell.com/supportforums/board/message?board.id=aximwireless&message.id=9140&c=us&l=en&cs=&s=gen

I found the patch, in case you have other Axim x51s, and am attempting to apply it now.

http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R112544&SystemID=PDA_AXIM_X51&os=PPM&osl=en&deviceid=7643&devlib=0&typecnt=1&vercnt=1&formatcnt=1&fileid=147229


It would be nice ( and beneficial to Franson ) to ask what platform is being used so that you can check it against all the deviced/platform etc. you support issues. I realize it would be a big task, but then you could always say "We have tested this code and examples on these platforms and they work for us". Just a friendly suggestion that will help you improve customer and potential customer, service.



David

scippy
Posts: 33
Joined: Sat Feb 04, 2006 4:37 pm
Location: Italy
Contact: Website

RE: Axim x51 License Issue

Thu Feb 16, 2006 5:22 pm

I'm working on Dell Axim x51v (mobile5) and all work ok!
You can see my authentication post if like see my code resume. http://www.franson.com/forum/topic.asp?TOPIC_ID=2315

Return to “BlueTools”