Page 1 of 1

Dongle USB and NAP

Posted: Tue Dec 06, 2005 4:26 am
by cirix81
I have a dongle bluetooth usb Conceptronic CBTU and a Network Access Point Conceptronic CBT100AP and i want use your api to connect automaticaly to the NAP Service. When I use your sample FindAndConnect, The following error apear:
- The connection failed due to an unknown error

What i need to connect automaticaly?

RE: Dongle USB and NAP

Posted: Tue Dec 06, 2005 11:32 am
by johan
What hardware are you using?

Maybe you need to bond to thre remote device first?

Regards,
Johan

Franson Support

RE: Dongle USB and NAP

Posted: Tue Dec 06, 2005 4:29 pm
by juao
We're using

Bluetooth usb dongle: Conceptronic CBTU

http://www.conceptronic.net/site/DesktopDefault.aspx?tabindex=1&tabid=200&Cat=10&grp=1020&Prod_ID=319&Prod=CBTU&st=1

and a Network Access Point Conceptronic CBT100AP

http://www.conceptronic.net/site/DesktopDefault.aspx?tabindex=1&tabid=200&Cat=10&grp=1020&Prod_ID=711&Prod=CBT100AP

in a Windows XP SP2 system, with WIDCOMM drivers.

We've also a BCM2035 BT adapter on a different machine with the same operating system, just for troubleshoot purposes, but we're getting the same problem

We're getting the devices found from Access Point (NAP device), and we do the the bond nicely...
But when we try to connect to NAP device (by selecting it in list of AP avaliable devices, comes an error "The connection failed due an unknown error".

We've tested different scenarios, also using your find&connect sample:

- We've connected to a NOKIA headset OK
- We've connected Conceptronic CBTU and BCM2035 from serial port OK

NOTE: We can connect and pair Conceptronic CBTU and BCM2035 with CBT100AP just fine with widcomm software via NAP Service.

Best Regards

Joao Oliveira

RE: Dongle USB and NAP

Posted: Tue Dec 06, 2005 6:35 pm
by johan
Ok, I see. I will send you a debug version to trouble shoot this.

Regards,
Johan

Franson Support