Page 1 of 1

PDA service connection problems

Posted: Tue Oct 18, 2005 9:35 am
by ScottA
Hi,

I'm trying to connect a bluetooth PDA to a bluetooth mobile printer, the Findandconnect example can find the device, list the "Serial Printer" service yet fails on connect. I have tried this on a dell x50v where it simply fails with a nice error message, and on a ipaq hx4700 where it seems to hang during the connection attempt.

Both PDA's have no problems connecting to the printer through the standard bluetooth manager and i'm developing using vs2005 beta2.

I also found (on both pda's) that if the findandconnect program had been run numerous times, or i had stopped the program abnormally that the pda gets into a state such that when next run, the findandconnect program will find no devices and will return instantly. Getting around this required a soft reset.

Any workarounds would be great.

RE: PDA service connection problems

Posted: Tue Oct 18, 2005 11:19 am
by johan
We are addressing those issues in the next beta release. You can subscribe to "Bluetools Updates" in this forum to get an email notification on minor and major updates.

Regards,
Johan

Franson Support

RE: PDA service connection problems

Posted: Wed Oct 26, 2005 12:04 pm
by Martin J
Hi!

I think the last problem has to do with the Widcomm stack as we experienced the same thing with another BT component (on PPC). I heard that you can have a maximum of eigth connections to the stack. So if your program crashes before connection (to the stack) is closed you'll have one less connection available next run. Finally you can't do anything and have to perform a soft reset.

/Martin J