nelsona
Posts: 8
Joined: Tue Oct 18, 2005 1:50 am

"Incorrect license type" message

Tue Oct 18, 2005 1:59 am

Downloaded 14-day trial and trying to run a test app on Win XP. Have the following in the constructor method:

Franson.BlueTools.License license = new Franson.BlueTools.License();
license.LicenseKey = "Wo...TF"; //license key

Get error message: "Incorrect license type"

I have copied and pasted, NOT a spelling issue. Using the dotNET license key sent to me via email (as opposed to the other one ie. dotNET compact framework...tried that one also didn't work).

Thanks in advance,

User avatar
johan
GpsGate
Posts: 15293
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: "Incorrect license type" message

Tue Oct 18, 2005 11:15 am

What is the exact error message you get?

Regards,
Johan

Franson Support

nelsona
Posts: 8
Joined: Tue Oct 18, 2005 1:50 am

RE: "Incorrect license type" message

Tue Oct 18, 2005 5:09 pm

A message box with exclamation mark and the following message:

Incorrect license type

That's it.

User avatar
johan
GpsGate
Posts: 15293
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: "Incorrect license type" message

Tue Oct 18, 2005 5:23 pm

This error message does not come from BlueTools. It comes from the WidComm stack/driver. You probably use a BT dongle which is not licensed for their stack. You can probably resolve this by installing the driver for your BT dongle, or switch to the Microsoft stack.

Regards,
Johan

Franson Support

nelsona
Posts: 8
Joined: Tue Oct 18, 2005 1:50 am

RE: "Incorrect license type" message

Tue Oct 18, 2005 6:27 pm

Hmmmm...not sure about that. I just checked my device manager and I am using the MS stack/driver. Driver provider: Microsoft, Driver version: 5.1.2600.2180

Under Bluetooth Radios in device manager:
- Blutonium BCM2035 Bluetooth 2.4 GHz Single Chip Transceiver
- Microsoft Bluetooth Enumerator

The message doesn't look like an error that is coming from WidComm driver, looks like it is generated by the Bluetools component.

Appreciate the help,

User avatar
johan
GpsGate
Posts: 15293
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: "Incorrect license type" message

Tue Oct 18, 2005 6:38 pm

If the exact error message says "Incorrect license type" then it doesn't come from the inside of BlueTools, since no such text string existst. It probably comes from the OS, or driver in some way. I have seen it from the WidComm driver under the circumstances I described.

Anyway. There will be a new version out very soon. If that version does not solve this issue, I'll send you a debug version to work this out.

Regards,
Johan

Franson Support

nelsona
Posts: 8
Joined: Tue Oct 18, 2005 1:50 am

RE: "Incorrect license type" message

Thu Oct 20, 2005 6:09 pm

The "Incorrect license type" message is coming from outside my test application and outside the bluetools component. It is initiated by the...

network.AutoDiscovery = true;

...statement in my network loop:

foreach(Network network in networks) {
network.AutoDiscovery = true;
}


Even after control leaves the loop (goes thru it once), the "Incorrect license type" message pops up every few seconds over and over.

Discovery is turned off by default in the Bluetooth config and i would like to turn it on in the code as shown above (in your sample code also).

What can i do right now to resolve this issue aside from waiting for the next version? I am using the MS stack/driver...any ideas?

Thx in advance,

nelsona
Posts: 8
Joined: Tue Oct 18, 2005 1:50 am

RE: "Incorrect license type" message

Thu Oct 20, 2005 6:17 pm

Just a quick fyi to my previous post...when i try to turn on discovery in the bluetooth configuration interface, i get the same error message when i attempt to apply the change.

Return to “BlueTools”