wendye
Posts: 2
Joined: Tue Dec 15, 2009 8:09 pm

"Bluetools.dll not installed" for Widcom stack

Tue Dec 15, 2009 8:26 pm

I have just downloaded and installed the BlueTools SDK v1.21 on my Windows XP SP2. I have a bluetooth dongle using the WidComm stack.
When I build and run the demo FindAndConnect (dotNet200) it works but of course no devices are found. When I add the following line so I can use WidComm:

Manager.StackID = StackID.STACK_WIDCOMM;

just before
manager = Manager.GetManager();

and run the application again, I get the error
"BlueTools.dll not installed. Please visit franson.com/bluetools for more info"

What's happening??

(By the way I did copy all the bluetooth.dll files from Windows\system32 to the sample's Debug\bin directory).

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: "Bluetools.dll not installed" for Widcom stack

Tue Dec 15, 2009 9:22 pm

You are probably forcing the manager to load Widcomm but the Widcomm stack is not installed or for some reason not loading properly. It is usually the best case to let the manger auto-detect the stack it should use. If it doesn't load Widcomm automatically it won't change anything by forcing StackID like that.

The error message is kinda non-informative though ;)

Regards,
Jonas

wendye
Posts: 2
Joined: Tue Dec 15, 2009 8:09 pm

RE: "Bluetools.dll not installed" for Widcom stack

Wed Dec 16, 2009 1:15 pm

Thanks for the info. At least now I know it is not a misplaced dll or something.

Unfortunately that does not solve my problem... any idea why Bluetools would not detect the correct stack? Because the dongle works fine on its own driver.

Return to “BlueTools”