Search found 12 matches

Go to advanced search

by michael29
Sat Jan 24, 2009 1:48 pm
Forum: BlueTools
Topic: Stack corruption
Replies: 12
Views: 5853

RE: Stack corruption

Originally posted by Jonas

Can you upload the project somewhere so I can test it?

Regards,
Jonas


According to the last posts I sent you my application in december wich uses the BlueTools library. Were you able to collect any new informations about the described problem above in the passed time?
by michael29
Tue Dec 16, 2008 5:24 pm
Forum: BlueTools
Topic: Stack corruption
Replies: 12
Views: 5853

RE: Stack corruption

Originally posted by Jonas No, it shouldn't be anything else that is required. I don't know why it's happening. Regards, Jonas I excluded definetly the possibility that there's an error in parts of my sourcecode rather than in the neccessary bluetools classes "Service", "ServiceStream", "RemoteDevic...
by michael29
Thu Dec 11, 2008 3:30 pm
Forum: BlueTools
Topic: Stack corruption
Replies: 12
Views: 5853

RE: Stack corruption

Originally posted by Jonas Closing all connections means Stream.Close() on all open connections. Calling GetManager().Dispose() is required on shutdown, it should be sufficient but closing all the open streams manually first is recommended. Regards, Jonas Yes, I always close the opened stream first ...
by michael29
Mon Dec 08, 2008 5:12 pm
Forum: BlueTools
Topic: Stack corruption
Replies: 12
Views: 5853

RE: Stack corruption

Originally posted by tix The temporary workaround that i found was to disbale all the stack via ipaq tools. This is ipaq specific and not a general solution. Thank you for your hint. Do you have a link for me to download the iPaq tools? But for the professional use I can't use this workaround, becau...
by michael29
Mon Dec 08, 2008 2:45 pm
Forum: BlueTools
Topic: Stack corruption
Replies: 12
Views: 5853

RE: Stack corruption

Originally posted by Jonas For Widcomm, no. Only thing I can recommend is that you close all connections properly when you disconnect. Regards, Jonas Hello, concerning to the stack corruption problem with Bluetools library I have another question: Currently I have the same problem under a HQ iPAQ PD...
by michael29
Fri Nov 14, 2008 8:06 pm
Forum: BlueTools
Topic: Show only paired devices
Replies: 1
Views: 1612

Show only paired devices

Hello, is it possible to show only already paired devices, without discovering with BlueTools? I have the problem, that the discovering process takes to much time for my application and it would be fine if there's a possibility. P.S: Currently I'm using the BlueTools under a HQ iPaQ PPC wich is usin...
by michael29
Mon Apr 07, 2008 3:18 pm
Forum: BlueTools
Topic: Failed to load bluetooth driver!
Replies: 13
Views: 8942

RE: Failed to load bluetooth driver!

Originally posted by Jonas MS stack? But then you can't get the exact same error I suppose? "Failed to load stack driver (BlueToolsWC.dll). Reason: [193] (null)"?? You are getting Failed to load stack driver (BlueToolsMS.dll) ? Sorry, not exactly, but it's the same error type, only with BlueToolsMS....
by michael29
Thu Apr 03, 2008 2:15 pm
Forum: BlueTools
Topic: Failed to load bluetooth driver!
Replies: 13
Views: 8942

RE: Failed to load bluetooth driver!

Originally posted by Jonas Unfortunately, I have no further information on this issue. Regards, Jonas Yesterday I wrote a simple bluetooth application based on the actual 32feet.NET library by InTheHand wich supports only MS stacks. I transferred the app to the same device (HTC Prophet) and now it w...
by michael29
Wed Apr 02, 2008 2:50 pm
Forum: BlueTools
Topic: Failed to load bluetooth driver!
Replies: 13
Views: 8942

RE: Failed to load bluetooth driver!

Originally posted by Jonas The error is basically that BlueTools can't find the necessary core DLLs. On a SmartPhone it's probably because they are simply not compatible or allowed to load (due to security settings). Regards, Jonas I have the same problem on a smartphone but there's a Microsoft blue...
by michael29
Fri Feb 15, 2008 3:04 pm
Forum: BlueTools
Topic: BlueTools.dll not found
Replies: 5
Views: 2579

RE: BlueTools.dll not found

Have you copied the core files too? BlueTools.dll, BlueToolsWC.dll and BlueToolsWC150.dll (for an iPaq). Thanks a lot. Now it works fine! I thought that all depended DLL's from the current project are automatically copied by ActiveSync to the device when I try to start the application on the device.
by michael29
Thu Feb 14, 2008 8:03 pm
Forum: BlueTools
Topic: BlueTools.dll not found
Replies: 5
Views: 2579

RE: BlueTools.dll not found

Have you copied the core files too? BlueTools.dll, BlueToolsWC.dll and BlueToolsWC150.dll (for an iPaq). I've forgotten the "BlueToolsWc150.dll". I copied it into the output directory from the project and tried it again. The error is still there. Is it correct if I just copy the files into the outp...
by michael29
Thu Feb 14, 2008 5:11 pm
Forum: BlueTools
Topic: BlueTools.dll not found
Replies: 5
Views: 2579

BlueTools.dll not found

Hi. A few days ago I got the trial version of BlueTools SDK and installed them. The application I intend to develop should communicate with other devices via bluetooth and run proper on a HP iPAQ PDA (hx2100 family). There's an bluetooth stack (V1.2) from WIDCOMM available on the HP iPAQ. I tried ou...

Go to advanced search