Search found 12 matches

Go to advanced search

by johnboyo
Thu Oct 19, 2006 3:27 pm
Forum: BlueTools
Topic: ServiceRecordHandle
Replies: 2
Views: 2262

RE: ServiceRecordHandle

Johan,

Can we attempt to fix this. I have been substituting the MS Stack as the ServiceRecord is populated fine with it, however I do need to move to the WIDCOMM stack very soon.

Thanks
John
by johnboyo
Wed Sep 13, 2006 5:17 pm
Forum: BlueTools
Topic: ServiceRecordHandle
Replies: 2
Views: 2262

ServiceRecordHandle

Hi

I'm having trouble with ServiceRecord not being populated with the Widcomm stack. Its version 4.0.1.2401 with the latest version of Bluetools (.NET 2.0). Is this a known problem?

Any advice?

Many Thanks
John
by johnboyo
Tue Feb 07, 2006 3:52 pm
Forum: BlueTools
Topic: Multiple Dongles
Replies: 2
Views: 2112

Multiple Dongles

Hi

Any ETA on when bluetools will support more than one dongle/network?

John
by johnboyo
Mon Feb 06, 2006 5:19 pm
Forum: BlueTools
Topic: Simultaneous Operations
Replies: 7
Views: 3571

RE: Simultaneous Operations

Ok, Thanks Johan

Just out of curiosity do you happen to know off hand any manufacturers of such Bluetooth Hardware?

John
by johnboyo
Mon Feb 06, 2006 5:09 pm
Forum: BlueTools
Topic: Simultaneous Operations
Replies: 7
Views: 3571

RE: Simultaneous Operations

Johan

If this was the case does Bluetools handle this event? i.e. does it pause the AutoDiscovery in order to do an OBEX Push? I have set my AutoRefreshInterval to 0 so during the OBEX Push is this not operating?

John
by johnboyo
Mon Feb 06, 2006 2:39 pm
Forum: BlueTools
Topic: Simultaneous Operations
Replies: 7
Views: 3571

Simultaneous Operations

Morning Guys I'm currently writing an unattended OBEX Push Application. I have noticed that when the AutoDiscover grabs two or more devices at once the app stops when trying to get service and push file. So my question, is it possible to thread it so simultaneous push's can take place or will the Bl...
by johnboyo
Tue Jan 10, 2006 10:57 pm
Forum: BlueTools
Topic: Discover, Out of Range and discover again
Replies: 4
Views: 3097

RE: Discover, Out of Range and discover again

Skumar

As johan has pointed out it is possible to set AutoDiscovery to 'true' which as the name suggests makes your code poll constantly (or at set intervals, which is set with AutoRefreshInterval) and fire events when a device is discovered and is lost.

John
by johnboyo
Fri Dec 09, 2005 6:07 pm
Forum: BlueTools
Topic: (unnamed bluetools entity)
Replies: 3
Views: 3132

RE: (unnamed bluetools entity)

Thanks Johan, I didn't realise the MS stack had a problem with this, although now it would explain problems I had in the past using the MS stack directly. :)

John
by johnboyo
Thu Dec 01, 2005 7:06 pm
Forum: BlueTools
Topic: (unnamed bluetools entity)
Replies: 3
Views: 3132

(unnamed bluetools entity)

Hi Guys On a machine running Microsoft Stack (fresh XP SP2 install). I run the following code to discover devices and add to a listbox. RemoteDevice device = RemoteDevice)((DiscoveryEventArgs)eventArgs).Discovery; deviceList.Items.Add(device); (taken from the find & connect sample) However instead o...
by johnboyo
Fri Nov 18, 2005 6:23 pm
Forum: BlueTools
Topic: RFCOMM Port
Replies: 2
Views: 2658

RE: RFCOMM Port

Yep got it thanks.

John
by johnboyo
Fri Nov 18, 2005 3:16 pm
Forum: BlueTools
Topic: RFCOMM Port
Replies: 2
Views: 2658

RFCOMM Port

Hi Guys Is it possible to retrieve the RFCOMM Channel number (as shown in bold in the below trace). If so which Class/Method in the API will provide this? Thanks John Service Name: Hands-Free Audio Gateway Service RecHandle: 0x10000 Service Class ID List: "Handfree Audio Gateway" (0x111f) "Generic A...
by johnboyo
Thu Nov 17, 2005 9:13 pm
Forum: BlueTools
Topic: Failed to Load Bluetooth Driver on HP4150
Replies: 4
Views: 2945

Failed to Load Bluetooth Driver on HP4150

Hi I tried to run the findandconnect sample c# script on my HP iPAQ 4150 but it returned the 'Failed to Load Bluetooth Driver' error. The bluetooth version is 1.4.1 Build 75 and I have loaded the dlls into the windows dir. Can you advise? I ran the same script on my HP iPAQ h6340 without any problem...

Go to advanced search