Search found 11 matches

Go to advanced search

by Martin J
Tue Dec 06, 2005 3:34 pm
Forum: BlueTools
Topic: Connect without searching
Replies: 9
Views: 5114

RE: Connect without searching

Hi ds303! This problem still occurs for me from time to time. You can read more about it in thread "Connection problem". Just like in your case a "hard reset" won't fix it, but there is a manual workaround for this: 1. Go into BT Manager and turn on BT 2. Set up a shortcut to some (any) units serial...
by Martin J
Wed Nov 23, 2005 7:13 pm
Forum: BlueTools
Topic: Connection problem
Replies: 11
Views: 5686

RE: Connection problem

No I mean "hard reset", as strange as it may sound. I have tried this many times and I was really surprised the first time I saw it. With beta7 I have seen sometimes that we succeed to connect after a "Connection failed" or "Connection timeout" which I don't think I saw before beta7. But in most cas...
by Martin J
Wed Nov 23, 2005 5:12 pm
Forum: BlueTools
Topic: Connection problem
Replies: 11
Views: 5686

RE: Connection problem

It still won't work unfortunately. One strange thing that may be of help for you is that after these errors turn up, even a hard reset is not enough to make the program work again. I have to connect and disconnect to Bluetooth serial port on some device via Bluetooth manager to get it to work again....
by Martin J
Thu Nov 10, 2005 3:31 pm
Forum: BlueTools
Topic: Connection problem
Replies: 11
Views: 5686

RE: Connection problem

Some more clues: The searching and connecting works fine until we eventually catch exception "Connection timed out" or "Connection failed" thrown by mystream = myservice.Stream We can also see that mystream is Nothing so no stream was opened, but after this we cannot connect to any device. The searc...
by Martin J
Mon Nov 07, 2005 5:31 pm
Forum: BlueTools
Topic: Connection problem
Replies: 11
Views: 5686

Connection problem

Hi! In our program (for Pocket PC) we search for devices and then for each device we connect, ask for some information and then disconnect. Usually after a couple of searches we can't connect to any device anymore, although searching for devices still works as it should. The only way to get it to wo...
by Martin J
Wed Nov 02, 2005 3:40 pm
Forum: BlueTools
Topic: AutoDiscovery = False hangs
Replies: 1
Views: 2134

AutoDiscovery = False hangs

Hello I turn on AutoDiscovery when my application starts. Whenever I want to communicate with a device I temporarily turn off AutoDiscovery (by setting AutoDiscovery = False). This works most of the time but sometimes it hangs the application. I now do some checks for DiscoveryPending before turning...
by Martin J
Fri Oct 28, 2005 4:40 pm
Forum: BlueTools
Topic: Signal strength?
Replies: 2
Views: 2798

Signal strength?

Hi!

I looked through the reference manual but I couldn't find any ways to read out the signal strength. Is that possible to do? Otherwise, do you plan to implement this?

Kind regards,
/Martin J
by Martin J
Fri Oct 28, 2005 4:38 pm
Forum: BlueTools
Topic: Second click on "Discover" -> services are lost
Replies: 4
Views: 3093

RE: Second click on "Discover" -> services are lost

Beta 6 works much better. Thanks!

/Martin J
by Martin J
Thu Oct 27, 2005 10:08 am
Forum: BlueTools
Topic: Second click on "Discover" -> services are lost
Replies: 4
Views: 3093

RE: Second click on "Discover" -> services are lost

Here is another clue. I inserted two error checks (see below) and tested the program in two ways: - First I just clicked on "Discover" several times. There where no error messages. If I set a breakpoint after nwork.DiscoverDevices() I can see in nwork.Devices that no device has any services (after t...
by Martin J
Wed Oct 26, 2005 5:12 pm
Forum: BlueTools
Topic: Second click on "Discover" -> services are lost
Replies: 4
Views: 3093

Second click on "Discover" -> services are lost

Hi! After trying the VB.NET sample for Compact Framework (using your Beta 5) I notice that after the second search for devices, some of the previously found devices no longer list any services. If I continue to search after that then no services are found on any device. I use VS.NET 2003 and iPAQ hx...
by Martin J
Wed Oct 26, 2005 12:04 pm
Forum: BlueTools
Topic: PDA service connection problems
Replies: 2
Views: 2726

RE: PDA service connection problems

Hi! I think the last problem has to do with the Widcomm stack as we experienced the same thing with another BT component (on PPC). I heard that you can have a maximum of eigth connections to the stack. So if your program crashes before connection (to the stack) is closed you'll have one less connect...

Go to advanced search