Search found 15 matches

Go to advanced search

by zelander
Thu Oct 05, 2006 12:37 am
Forum: BlueTools
Topic: License key don´t work.
Replies: 8
Views: 4084

RE: License key don´t work.

Hi! Did test the key in connect and find example and it did work so i run a debug of my code. The "licence exeption" is thrown when i try to check "Networks.Length". (Used that code to check if ther´s a bluetooth dongle installed). Have disabled that line of code and now everything is working as sup...
by zelander
Fri Sep 29, 2006 7:35 pm
Forum: BlueTools
Topic: License key don´t work.
Replies: 8
Views: 4084

RE: License key don´t work.

Havn´t had a chance to test that yet, will do when this evening. I´ll come back to you after that.

Regards/
Bjoern
by zelander
Fri Sep 29, 2006 7:20 pm
Forum: BlueTools
Topic: License key don´t work.
Replies: 8
Views: 4084

RE: License key don´t work.

>The error you get indicates that you haven't executed the license key statment. Please take a >look at the samples in the SDK for how to do that. Explain to me why the "development" key works then? The only change I´m doing is changeing the key in the config file, and restarts bootup of application...
by zelander
Fri Sep 29, 2006 4:55 pm
Forum: BlueTools
Topic: License key don´t work.
Replies: 8
Views: 4084

RE: License key don´t work.

Hi. 1. The key is read from a xml-file. No coding change to change key. As said before, developer keys do work. Bought key don´t. The exception is fired when trying to connect to Networks[]. Error message is something like (Licensekey is invalid, please check "your url"). 2. We have bought the key f...
by zelander
Thu Sep 28, 2006 2:21 pm
Forum: BlueTools
Topic: License key don´t work.
Replies: 8
Views: 4084

License key don´t work.

Hi. We resently bought your product (via internet). Sadly the licensekey doesn´t work. We have tested the key in different computers, but without luck. After contact with you (by mail), you sent us another key but that doesn´t work either. Developer keys works though... The key is for .NET desktop. ...
by zelander
Thu Dec 29, 2005 6:49 pm
Forum: BlueTools
Topic: Problem discovering twice
Replies: 4
Views: 2943

RE: Problem discovering twice

1. Don´t move dispose.
2, Check boolean variable if bluetools is in "searchmode". Don´t remember the name right now.
3. If not in search. Call search...

(Not sure of this, but as I can remember it was how i solved it 3 mounth ago)

/Bjoern
by zelander
Thu Dec 29, 2005 6:38 pm
Forum: BlueTools
Topic: How to utilize serial port profile.
Replies: 4
Views: 3296

RE: How to utilize serial port profile.

Hi Mark, It does work just sending the bytes, but you got to have the same default settings in both BT-module (remote) and local. If not, u need to send a HCI command to remote module to tell it what speed it should and settings i should use to communicate through hardware UART. Haven´t find the sol...
by zelander
Wed Oct 26, 2005 1:00 pm
Forum: BlueTools
Topic: Error when opening stream in "Find & Connect" ex.
Replies: 6
Views: 3825

RE: Error when opening stream in "Find & Connect" ex.

I don´t think you really understood my question. I do send one byte as you told, with flush and so on, but the pic processor "behind" my hardware module on "the other side" can´t read that byte. I think this is because the default UART settings in remote hardware module are wrong, and there will be ...
by zelander
Wed Oct 26, 2005 12:59 am
Forum: BlueTools
Topic: Error when opening stream in "Find & Connect" ex.
Replies: 6
Views: 3825

RE: Error when opening stream in "Find & Connect" ex.

Quite old dongle, so it´s possible that the driver is old also... Just one last question: When I find a connection I want to send one byte (to tell the remote device to initiate some data transfer). Unfortunately I can´t send any data prior to receive from the remote device. I think that´s because t...
by zelander
Tue Oct 25, 2005 11:41 pm
Forum: BlueTools
Topic: Error when opening stream in "Find & Connect" ex.
Replies: 6
Views: 3825

RE: Error when opening stream in "Find & Connect" ex.

Uninstalled Widcomm drivers and installed the Microsoft Stack. Now it seems like The Find and Connect example is working.. At least no exception.

/Björn
by zelander
Sun Oct 23, 2005 10:31 pm
Forum: BlueTools
Topic: Error when opening stream in "Find & Connect" ex.
Replies: 6
Views: 3825

Error when opening stream in "Find & Connect" ex.

Hello Have just downloaded the new BETA 5 drivers for bluetools and the "Find and Connect" example still can´t open the datastream. The application throws an errormessage like: "Failed to set the security level of the connection. Try restarting the bluetooth stack." The module I´m connection to has ...
by zelander
Sat Oct 15, 2005 3:44 pm
Forum: BlueTools
Topic: Bete4 bug?
Replies: 2
Views: 2588

RE: Bete4 bug?

Window XP SP2 (widcomm bt drivers)
by zelander
Fri Oct 14, 2005 10:01 pm
Forum: BlueTools
Topic: How to utilize serial port profile.
Replies: 4
Views: 3296

RE: How to utilize serial port profile.

Thanks for the replay... The problem is that I´m interacting with a "complete" stand-alone module from Free2Move which only utilizes the SPP. That´s why i need to use the SPP. (Can´t change or program the other side). The document you refered to didn´t tell anything about how the HCI package should ...
by zelander
Fri Oct 14, 2005 9:32 pm
Forum: BlueTools
Topic: Bete4 bug?
Replies: 2
Views: 2588

Bete4 bug?

Downloaded new Beta4 SDK(for serial communication example). I uninstalled old SDK and installed the new one. Now bluetools can´t find my bluetooth devices no more. If I run in debug, I can see that the local module exist in "networks" list in FindAndConnect example. The event "DeviceDiscoveryComplet...
by zelander
Thu Oct 13, 2005 1:14 pm
Forum: BlueTools
Topic: How to utilize serial port profile.
Replies: 4
Views: 3296

How to utilize serial port profile.

Hello. I´m developing an application which is searching for bluetooth modules through franson bluetools api. When a module comes online I would like to send simple messages with the serial port profile. (The module can only handle SPP). So, how do I transform the SPP service binary stream to a valid...

Go to advanced search