User avatar
johan
GpsGate
Posts: 14300
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

FIX: Not supported framework version: Net 4.6

Wed Jan 25, 2017 12:15 pm

ERROR

You get a message saying "Not supported framework version: Net 4.6" when trying to install or upgrade a plugin.

CAUSE

The plugin you try to upgrade to or install is dependent on .NET 4.6

SOLUTION

STEP #1 Install .NET 4.6

When this is done, please install .NET 4.6 on your Windows server (requires reboot)
https://www.microsoft.com/en-us/download/details.aspx?id=48130

Please note that GpsGate only support Windows versions that are also supported by Microsoft. This means Windows 2003 and XP are not supported.

STEP #2 Update plugins

As a first step, please make sure that Patch.v4 is up to date (from update.gpsgate.com)

If you update from Patch.v4 4.0.0.4900 (Dec 2016 release) or earlier, please read this:
http://forum.gpsgate.com/viewtopic.php?f=29&t=19666

1. Login to SiteAdmin
2. Go to Plugins
3. Update Patch.v4
4. (It is recommended that you update all plugins, but not necessary).

STEP #3 Activate .NET 4.6

1. Login to SiteAdmin
2. Go to Plugins
3. Go to Target Framework (left menu)
4. Activate .NET 4

If you get an error message when in SiteAdmin after enabling .NET 4, please make sure ASP.NET 4.5 is enabled on your Windows server.

For Windows 2012 / Windows 8 and later please run the following command from an administrative command prompt to enabled ASP.NET 4.5

Code: Select all

dism /online /enable-feature /featurename:IIS-ASPNET45
For Windows 2008 / Windows 7 / Vista, please run this command:

Code: Select all

C:\Windows\Microsoft.NET\Framework64\v4.0.30319>aspnet_regii‌​s -i
STEP #4 Upgrade/Install the plugin!

Now it should work!!

If you still have problems, please contact support @ gpsgate.com
Regards,
Johan

GpsGate Support

Return to “GpsGate Server - How to setup and use”