kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

GpsGate silent installation and service install

Fri Jan 18, 2008 11:41 am

Hi,

I’m having problems doing a silent installation of GpsGate v2.6.0.292, and afterwards installing it as a service.

The process is as follows:
GpsGate.exe /s /v”/qn”
Run small reg file that sets UseSharedSettings
Copy Xml Configuration files for Input and output port, to Gps gate install path
Run GpsGate (works fine, get input and all)
Exit GpsGate
GpsGateService.exe /service
Try and start service, and get a 1053: error that service did not start in time

IF I install GpsGate, though GUI at first and follow the same procedure, the service works and no problems.

Please help?

/kimbor

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Fri Jan 18, 2008 12:20 pm

Test 1
If you run the normal installation program, not the silent one, will that install the service in a way you can start it?

Test 2
If you run GpsGateService.exe /service from a DOS prompt, and not from your script. Does that install the service in a way you can start it?

While testing you can unregister the service by
GpsGateService /unregserver

You can also register it as a "local service" using
GpsGateService /regserver

You can check in the Control Panel if the service is registered or not, and if it is started or not, and if it will start at boot or not. The name of the service is "Franson GpsGate 2.0"

Regards,
Johan

Franson Support

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Fri Jan 18, 2008 1:02 pm

Test1
If I run the normal installation and not the silent one, no service is installed. I have to install it from DOS Prompt (GpsGateService.exe /service) and the service then works.

Test2
I run GpsGateService.exe /service from a DOS prompt and not a script, no automation to keep it simple at first.
Will only work as i stated earlier if i run at "normal" install and not if it's been installed through silent installation.

If i try using GpsGateService /regserver from a DOS Prompt, as you state no service is registered under the name "Franson GpsGate 2.0" only when i run GpsGateService /service.

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Sat Jan 19, 2008 9:48 pm

I managed to repeat your error, and we have hopefully found a solution.

This seems to be a security issue related to how the GpsGateService.exe is copied and registered. My guess is that MS has tightened up security in recent live updates of Windows.

Anyway, I think we have a solution for this now. I will send you an updated install program. And the fix will also be included in the next service release of GpsGate (later than build 294)

Regards,
Johan

Franson Support

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Thu Jan 24, 2008 6:59 pm

Hi,

I tried the new build, and I am now able to install and start the service. BUT now I am not able to actually read from the VPorts that’s configured. I’ve tried our own developer software and 3rn party software none is able to read from the VPorts IF it’s running as a service. If I shutdown the service, and run the GUI version instead, it works like a charm.
I’ve used the same installation process, as before.

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Thu Jan 24, 2008 9:05 pm

Do you get the service to work when you do a normal install?

Are you sure you have set the "UseSharedSettings" correctly?

Configure GpsGate to use shared settings:
HKEY_LOCAL_MACHINE\Software\Franson\GpsGate
DWORD: UseSharedSettings = 1

Note that it should be set under HKEY_LOCAL_MACHINE

Regards,
Johan

Franson Support

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Fri Jan 25, 2008 11:01 am

Yes the service works with a normal install. The normal install installs the service, and with the silent i have to run GpsGateService.exe /service to get it installed.

Yes the UseSharedSettings are correct, even double checked by launching the GUI version of gpsgate, and change the option through the settings in there.

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Fri Jan 25, 2008 11:02 am

Have you started the service?

net start "Franson GpsGate 2.0"

Regards,
Johan

Franson Support

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Fri Jan 25, 2008 11:15 am

[:)] yes

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Wed Feb 06, 2008 12:44 pm

Do you need any further information from us, to solve the problem?

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Wed Feb 06, 2008 12:59 pm

I cannot repeat the problem.

Regards,
Johan

Franson Support

kimbor
Posts: 9
Joined: Tue Dec 11, 2007 3:03 pm
Location: Denmark

RE: GpsGate silent installation and service install

Wed Feb 06, 2008 1:26 pm

What can we do to help you recreate the problem? Do you have a version with debug/logging that we can try and install, to help you find the problem or?? Do you need any OS information etc.?

mikesmobile73
Posts: 1
Joined: Sat Sep 19, 2015 8:56 am
Location: USA

RE: GpsGate silent installation and service install

Sat Sep 19, 2015 8:59 am

Hi. Which XML config files do I need to work with?


Originally posted by kimbor

Hi,

I’m having problems doing a silent installation of GpsGate v2.6.0.292, and afterwards installing it as a service.

The process is as follows:
GpsGate.exe /s /v”/qn”
Run small reg file that sets UseSharedSettings
Copy Xml Configuration files for Input and output port, to Gps gate install path
Run GpsGate (works fine, get input and all)
Exit GpsGate
GpsGateService.exe /service
Try and start service, and get a 1053: error that service did not start in time

IF I install GpsGate, though GUI at first and follow the same procedure, the service works and no problems.

Please help?

/kimbor

User avatar
johan
GpsGate
Posts: 14202
Joined: Wed Aug 04, 2004 10:40 pm
Location: Sweden
Contact: Website

RE: GpsGate silent installation and service install

Sat Sep 19, 2015 10:09 am

How to deploy GpsGate without user interaction on Windows
topic.asp?TOPIC_ID=4618

Regards,
Johan

GpsGate Support

ManHo
Posts: 2
Joined: Fri May 19, 2017 12:50 pm

Re: GpsGate silent installation and service install

Fri May 19, 2017 12:51 pm

I Like this page
If u want play casino online all games
Please Click Here this post
Wish all u Good Luck
Thanks You!!!
บาคาร่า
goldenslot

Return to “GpsGate Splitter - How to setup and use”