Nigel C
Posts: 7
Joined: Fri Dec 15, 2006 6:35 pm

Native exception in WM5

Fri Aug 22, 2008 1:51 pm

Device : Mobile Compia M3 Sky
Processor: ARM920T
Windows Mobile 5.0
Microsoft BT stack 5.1.0.478
.net CF 2.0

I have a problem with the application I'm writing in that the app shuts down during Device Discovery. No error message or exception is thrown, the app just shuts down and if running in Debug mode Visual Studio reports that connection with the device has been lost.

To check it's not my code I've tried running the VB and C# FindAndConnect samples, both fail during Device Disovery. The VB sample throws an error message on the device - "A native exception has occured in ...".
Exception Code: 0xc0000005
ExceptionAddress: 0x010831b0
Reading: 0x00000004

Any ideas?

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Native exception in WM5

Fri Aug 22, 2008 1:52 pm

Yes, I will release a new BlueTools version this weekend which will address this bug.

Regards,
Jonas

Nigel C
Posts: 7
Joined: Fri Dec 15, 2006 6:35 pm

RE: Native exception in WM5

Fri Aug 22, 2008 1:56 pm

Thanks for the prompt response. That's saved me a lot of headaches.

Nigel C
Posts: 7
Joined: Fri Dec 15, 2006 6:35 pm

RE: Native exception in WM5

Wed Aug 27, 2008 3:28 pm

Tried installing build 1.2.1.848 and I still get the same error.

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Native exception in WM5

Wed Aug 27, 2008 3:35 pm

That's strange.
I'll send you a trace version tonight to determine why it is crashing.

Regards,
Jonas

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Native exception in WM5

Wed Aug 27, 2008 7:33 pm

Are you using the ARM or the ARM4Vi DLLs?

Regards,
Jonas

Nigel C
Posts: 7
Joined: Fri Dec 15, 2006 6:35 pm

RE: Native exception in WM5

Thu Aug 28, 2008 3:33 pm

I was installing using the BlueTools.arm.CAB file, as there isn't an armv4i cab.

Have tried manually copying over both ARM and ARMv4i DLL and get the same error with either version.

Jonas
Posts: 2319
Joined: Mon Jan 09, 2006 2:20 pm
Location: Sweden

RE: Native exception in WM5

Thu Aug 28, 2008 4:39 pm

I will send you trace DLLs tonight then.

Regards,
Jonas

BBBBDawg
Posts: 1
Joined: Fri May 14, 2010 11:33 am

RE: Native exception in WM5

Fri May 14, 2010 11:38 am

Did this ever get resolved?
I've just got a brand new M3 in my hand and get the same thing on Device Discovery.

"Microsoft Bluetooth stack is not present or turned off. Failed to lookup the next device".

Perhaps they've changed the stack? Is there an alternative stack to Microsoft and Widcomm? I'm going to do some searching.

Return to “BlueTools”